RPM oscillations on yaw

I am working on a 1.2m Quad with Pixhawk. First I had problems with the green Turnigy Multistar ESC, but after flashing SimonK they work very smooth and sensitive.

Now the problem: When increasing yaw over 50% the two slower rotating motors start to oscillate in their RPM at about 10Hz. This happened in flight (with a successive crash) but also when the copter is tied down stationary.

Here is a screenshot from the logs, it looks like the oscillations are coming from the flightcontroller RCOU.Chan1-4 (note: the log frequency is much lower than the oscillation frequency):

3691154456?profile=original

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I found the root cause: The Multistar ESCs are loosing sync with the Multistar motors (hello HobbyKing). No stuttering with Turnigy Plush. But those are slow at regulating RPM, so I am looking for fast ESCs that work with those motors.

  • MR60

    Hi Erik,

    Looking at your videos I really feel you have a frame/hardware issue. First you have an H frame configuration combined with a really big size. H frames are known to have Yaw problems (because of the frame flexing) and you increase even more the flexing issue with a bigger size. Your frame does not look very rigid on the video, you can see it flexing like marshmallow.

    Second, the sound of your motors do not sound very good, it is like they are rubbing on something!?

    If I were you I would modify the frame to be in a X rigid form factor with the same motors,escs,props and see if then your issue remains or not. That test would define if it is a software or hardware root cause.

    • The bad sound of the motors is _because_ of the oscillations.

      Regardless: I don't get them with props removed. So it has to be some resonance between the props and the Pixhawk coupled over flexing frame. Will have to stiffen the frame.

      Btw MOT_SPIN_ARMED doesn't work anymore with the 3.2 rc10 firmware. And with 3.1 changes to MOT_SPIN_ARMED and THR_MIN_SPEED are only active after a reboot.

  • Developer

    @ Xian06 What issue are you referring to? I am not aware of an issue that causes this that is fixed in rc10.

    Hi Erik,

    To answer your question about why this isn't an bug report for github. Basically this has not been identified as a problem with the code. Instead it is most likely a problem with your tuning or hardware choices and setup. Until we can establish there is a problem to fix with the code we keep these issues on the forum. Here people will work with you to work out the problem and help you fix it. A but report is you helping us fix a problem with the code.

    Could you post a log so I can look at your issue myself. I have a large hex with a similar setup but running on 4s. I didn't have any problems with the Multistar 45 A Opto  esc's and so far the copter has performed beautifully.

    • Maybe this change?

      ArduCopter 3.2-rc8 11-Sep-2014
      Changes from 3.2-rc7
      1) EKF reduced ripple to resolve copter motor pulsing



      • Developer

        Hi Erik,

        Maybe but I don't think so. What version are you using, do you have EKF on?

        Again, your log helps here.

  • Known issue maybe repaired in rc10.

    • Would using an older firmware version fix the problem until rc10 is out?

      • You can install Rc10 in Mission Planner beta.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…