Hi everyone,

I've flown my Quad + Pixhawk twice and it worked GREAT.

Then I started to tweak things in APM Mission Planner to get the Tarot Gimbal tilt control working. Now it does.

But I must have messed with some parameters in the progress: I tried to fly yesterday and the quad wobbles like crazy.

Only tried in stabilize mode.

When I push the throttle (around half the stick), it starts to wobble on the roll axis quite hard, up to the point where it gets out of controll with motors alternatively spinning different RPM/almost stopping.

I thought it was a motor issue.

I changed all 4 and the problem is still here.

I changed propellers... same problem.

I calibrated again the ESCs... no luck

I reinstalled the arducopter firmware... same

I then thought I may have changed some parameters without knowing in APM Mission Planner.

I completely uninstalled the software and reinstalled a clean version to have the "factory settings" back.

Problem is still here.

Could this be caused by wrong PID settings I would have messed with in APM Mission Planner?

I attached screenshots of the settings.

Do they look right?

Also, I tried to push the throttle hard without the propellers on and it seems to be working fine...

I'm getting crazy.

Don't know what I changed, but I shouldn't have... :(

Thanks for all the help!

Mathieu

Configuration:

Frame: TBS Discovery

Pixhawk running arducopter 3.1.x (last version released) + 3DR GPS (+ compass) + 3DR telemetry

ESC: Afro ESC 30Amp Multi-rotor Motor Speed Controller (SimonK Firmware) 

Motors: NTM Prop Drive Series 28-26A 1200kv / 286w (short shaft version)

Battery: Turnigy nano-tech 4500mah 4S 35~70C Lipo Pack

Tl;dr Quad worked fine, tried to control gimbal tilt through Pixhawk, messed with APM Planner parameters (most probably),

now quad wobbles like hell and is impossible to control,

I'm lost and frustrated, and begging for help ;)

Screen Shot 2014-04-12 at 7.37.38 PM.png

Screen Shot 2014-04-12 at 7.37.48 PM.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Good screen shots.  adjust the pitch/roll rate 30% of the way to the right and test again.

    I had the same problem with the default settings... but this is something  you need to adjust.

    Also if it helps I have to adjust this when I switch prop sizes and prop types. 

    • Sorry Jerry,

      I totally missed your reply.

      Again, I got it fixed by resetting everything.

      I suspect I messed with PID settings when I was trying to configure the gimbal. I may have assigned the channel 6 knob to PID tuning and probably changed them while crazily turning the knob to see the gimbal tilt.

      Thanks again for taking the time to reply.

      Cheers,

      Mathieu

  • OK,

    Somehow I got it fixed by

    - deleting apm planner + parameters, and reinstall it clean,

    - reinstalling arducopter firmware several times on the Pixhawk, (and once installing arduplane firmware, then reinstalling arducopter)

    - pushing the reset button on the pixhawk's right side

    - resetting eeprom via CLI.

    Not sure which step fixed the issue, but now the crazy wobblings are gone and I can confidently crash my quad :)

    Mathieu

  • Sorry, I forgot to mention that, of course, I tried several times to recalibrate the accelerometer, the compass, the RC, and made sure the right frame type was set.

    No luck at all...

    Thanks again to everyone.

    Mathieu

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…