Hi everyone,

I've flown my Quad + Pixhawk twice and it worked GREAT.

Then I started to tweak things in APM Mission Planner to get the Tarot Gimbal tilt control working. Now it does.

But I must have messed with some parameters in the progress: I tried to fly yesterday and the quad wobbles like crazy.

Only tried in stabilize mode.

When I push the throttle (around half the stick), it starts to wobble on the roll axis quite hard, up to the point where it gets out of controll with motors alternatively spinning different RPM/almost stopping.

I thought it was a motor issue.

I changed all 4 and the problem is still here.

I changed propellers... same problem.

I calibrated again the ESCs... no luck

I reinstalled the arducopter firmware... same

I then thought I may have changed some parameters without knowing in APM Mission Planner.

I completely uninstalled the software and reinstalled a clean version to have the "factory settings" back.

Problem is still here.

Could this be caused by wrong PID settings I would have messed with in APM Mission Planner?

I attached screenshots of the settings.

Do they look right?

Also, I tried to push the throttle hard without the propellers on and it seems to be working fine...

I'm getting crazy.

Don't know what I changed, but I shouldn't have... :(

Thanks for all the help!



Frame: TBS Discovery

Pixhawk running arducopter 3.1.x (last version released) + 3DR GPS (+ compass) + 3DR telemetry

ESC: Afro ESC 30Amp Multi-rotor Motor Speed Controller (SimonK Firmware) 

Motors: NTM Prop Drive Series 28-26A 1200kv / 286w (short shaft version)

Battery: Turnigy nano-tech 4500mah 4S 35~70C Lipo Pack

Tl;dr Quad worked fine, tried to control gimbal tilt through Pixhawk, messed with APM Planner parameters (most probably),

now quad wobbles like hell and is impossible to control,

I'm lost and frustrated, and begging for help ;)

Screen Shot 2014-04-12 at 7.37.38 PM.png

Screen Shot 2014-04-12 at 7.37.48 PM.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Good screen shots.  adjust the pitch/roll rate 30% of the way to the right and test again.

    I had the same problem with the default settings... but this is something  you need to adjust.

    Also if it helps I have to adjust this when I switch prop sizes and prop types. 

    • Sorry Jerry,

      I totally missed your reply.

      Again, I got it fixed by resetting everything.

      I suspect I messed with PID settings when I was trying to configure the gimbal. I may have assigned the channel 6 knob to PID tuning and probably changed them while crazily turning the knob to see the gimbal tilt.

      Thanks again for taking the time to reply.



  • OK,

    Somehow I got it fixed by

    - deleting apm planner + parameters, and reinstall it clean,

    - reinstalling arducopter firmware several times on the Pixhawk, (and once installing arduplane firmware, then reinstalling arducopter)

    - pushing the reset button on the pixhawk's right side

    - resetting eeprom via CLI.

    Not sure which step fixed the issue, but now the crazy wobblings are gone and I can confidently crash my quad :)


  • Sorry, I forgot to mention that, of course, I tried several times to recalibrate the accelerometer, the compass, the RC, and made sure the right frame type was set.

    No luck at all...

    Thanks again to everyone.


This reply was deleted.


DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
DIY Robocars via Twitter
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
DIY Robocars via Twitter
RT @chr1sa: We've got a record 50 teams competing in this month's @DIYRobocars @donkey_car virtual AI car race. Starting today at 10:00am…
Nov 7
DIY Robocars via Twitter
Nov 6
DIY Robocars via Twitter
RT @a1k0n: Car's view, using a fisheye camera. The ceiling light tracking algorithm gave me some ideas to improve ConeSLAM, and having grou…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: To get ground truth I measured the rug, found the pixel coordinates of its corners, calibrated my phone camera with my standard…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: @DIYRobocars is back in December, but outside. Time to reinvestigate ConeSLAM! I rigged up a quick and dirty ground-truth captur…
Nov 5