Radio Calibration Problem Turnigy 9X

First of all I have to say that I'm completely new to the RC world.

Today I just finish assembling an quadcopter kit from jDrones. I loaded the latest firmware onto the APM 1 and everything seems to be working fine, but when I try to setup for the first time in the Radio Calibration page, when I move the sticks on my turnigy 9x, nothing happen. I saw that the bars on the wiki page ( what it is suppose to be) is green, but on mine, it's blue. I'm not quite sure what I'm missing here because I've never done this before, but I think I've followed the instruction correctly.

Is there anything extra that I'm suppose to do to make the Turnigy 9X (stock) work with APM1?

Some extra observations:

  • I think I have paired the tx with rx correctly since the red light on the rx is solid and only turns on when I turn my radio tx on.
  • The blue CPPM LED light on the red APM 1 board flash rapidly at first, but when I start moving the throttle on the turnigy 9x, the led starts to flash slower depending on I far I push the throttle. If I push it all the way up, the led flash very slowly, but if I push it all the way down, the led flash faster.
  • The green and red light on the IMU/Oil Pan board flash - Assume that this has nothing to do with rx/tx

Does anybody have an idea about what I could possibly miss or what newbies often miss?

Let me know if you need more information.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hello, di you solve this problem? I am having the same.

  • In my limited experience I've noticed that as I increase throttle the blue led flashes faster.  It's possible you will need to "reverse" the throttle control in the 9X.  APM will not arm at any throttle setting other than low/off. Also rudder/yaw channel must be set to full 100% range (i.e. you can not be in a lower dual rate rudder setting) when attempting to arm the apm.

  • This is what I got when I tried to calibrate the radio in the first time setup. The APM doesn't seem to get any signal from the rx. However, when I connect the esc directly to the rx, they all work (motor spins), but ch5-6 is not controllable by the tx.

    3692473153?profile=original

  • hi I have the stock 9x, after binding it worked first time, did you set up a new model, have you got it in mode 2 or mode 1 ? if you go into the menu you cna look at the display to make sure that the channels are funcitonal,

    i would try connecting an esc(with no prop) directly to the throttle chanel to see if there is any output, or connect a servo if you have one,

    be warned, my 9x seems to glitch on some channels and give bad output, and like previously mentioned, there is no failsafe, so if i lose rc the motors shut down,

    take it nice and easy on the first few flights, if i were ou i would practice altitude control and combatting the wind for several batteries worth before i flew more than a few meters away

  • Rx to APM 1 connections
    3692472225?profile=original3692472125?profile=original3692472247?profile=original

  • Are you using the receiver that comes with the 9x?

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…