This is sold at the DIYdrones store. I bought one - and I can fine no pictures manuals YouTube videos - zip, 0, 0.

Remzibi OSD 3DR- references can't be found.

Remzibi has not posted on RCuniverse, or DIYdrones for ~ six months.


Does anyone know why I can't find info on this OSD. Its a purple board with two button switches.

Every reference refers to early versions (red).


Please - bernienepper

Views: 4216

Reply to This

Replies to This Discussion

Wiki is here. The reason why there is not much info is that it is only new. Rembizi OSD has been around sine 2008 I think? Anyway a lot longer. 

Ardupilot Mega MinimOSD

 This is what your talking about


Remzibi OSD 3DR

This is what I'm talking about


I think that Remzibi OSD 3DR is from this design.

posts 3884 and 3885 give the impression it's the same OSD board.

Ah right you are. Should have read more carefully

Just thought I'd share some notes so far. I have it working with a seperate GPS module right now and editing the HappyKillmore Remzibi editor exe.


Thanks for sharing this information about pins.

A question please: Which pin is used for "Virtual ADC which keeps a running total for use with battery MAH consumption"?

It is done through the ADC 6 input and calculated in the Remzibi code on the ATmega32.

I'm using the Attopilot 90A sensor and works great. I am using a gain of 0.14286 on the advanced ADC config tab.


Hi there.

Manual is here:

Do not update Firmware until further details are released, i updated mine and it doen not work anymore :(


Unfortunately I read this post later.
This morning I received my Remzibi 3DR, and tried to update it.
Indeed it has stopped working and the blue LED is not lit.
Someone may be taking a hand? . Would be very grateful, I'm standing with a plate paperweights called remzibi

Thanks for the manual. I did find it after I was able to make my setup running. Question: In manual it says the Mediatek GPS cumes with firmware for APM and will not work as default with Remzibi and need to change the GPS firmware. I did NOT do that upgrade, I did simple plug the GPS to Remzibi and it worked normal. I see the Lat/Lon coordinated, 10 satellites, blue fix led. Should I really do a GPS firmware upgrade since GPS seems to work fine with default firmware?

And last question: couple of time GPS altitude displays negatives values. I do resetting home, it put to 0zero altitude, but later seconds show negatives. Not always. And couple of times the altitude does not vary, even the model altitude change visible. All the other values (Lat/Lon/Speed) looks OK. Any clue?

Hi there,

Upgrade the GPS to the recommended firmware and check if that solves it. Normally it should be fine. Dont forget to switch rx / tx on the FTDI cable when you connect to the GPS (use some jumper wires).


Hi Keith, do you know a way to enable/disable Remzibi OSD output using a spare channel from TX?

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service