RTL strange behaviour

I did a first test with RTL on 2.5.3 today. After GPS fix I took off ans steered the copter away from me in STAB mode. Went to RTL mode and watched the copter reaction. Instead of coming back he continued to move away. Does anybody has an idea that could help! Was doing the test with another ardufan. Had the same version and it all went OK on his copter. Very strange.Any help is highly appriciated.Jan

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Lloyd,

    Thanks for your feedback. You might be right. At first I thought to see a similar graph like Randy showed in this post. However now I took a closer look and have no more trust in my MAG. Looks like I have to replace it and see the effect. In the mean time, if somebody else on the forum has an opinion about this, please share.

  • Unfortunatly the Mag fix didn't solve the RTL issue. Did a test last weekend and same issue appears. When switching to RTL, the copter flew further away instead of coming back to launch. I attach the logfile and sketch about what happened. Armed copter after 3D fix so would assume that's his 'home' position. Hopefully somebody on the forum can give me some tips or advice.


    2012-04-30 21-03 19.log


  • I've engaged the RTL on my Hex a couple of times and watched as it took off due north and down with the RTL point set due west.  I had GPS lock for nearly 2 minutes, armed and flew east and up probably 100 meters each and engaged RTL to watch it make a mad dash for some very tall trees to the north. I let it go for what seemed like a long time, just to see if it would correct and just prior to smashing into the trees I switched back to stab mode and recovered the Hex maybe 30 feet short of the tree line.  I probably came down 50 meters and went north 75 meters.  After this I landed, disarmed, disconnected the battery and fired it all back up and tried again, with nearly the same result.( I decided to abort the RTL much sooner on the second attempt). 

    I don't have a magnetometer, is one required for RTL?  Are there some PID settings that will slow the pace of the mad dash of RTL so that I can do further testing at a lower risk of crash?





  • I had this happen in the very early days.

    Have you verified the magnometer is working correctly.

    In my case it was not and the quad just flew away.

    Luckily it hit a tree before it got too far.

    Also make sure you have got a solid red light on the oilpan, not just solid blue on the gps.

    By the way the magnometer is my most troublesome piece of equipment.

  • Very Curious as well.  I have tried RTL via channel 7 a few times.  In all cases waited for a blue GPS lock, armed motors an few straight ahead about 100 feet in the same direction.  Hit RTL and quad did anything but fly straight back as expected.  It went right one time, left, away ect.. nothing predictable.  Furthermore its unpredictability was a quite a high rate of speed which was fun to wrestle with :)

    I will try again as I just figured out how to get logging working and see if the results are similar. (My dataflash card was giving me a problem).

  • 3D Robotics

    Please post the logs. 

  • I can concur. I was the ardufan ;-).

    First attempt we waited for 3D fix before arming. The wiki mentions this.

    Then lifted off and flew a couple of metres and switched to RTL.The quad went left forward in the other direction from where we armed.

    To make sure we turned 180 degrees and did the same test. Again it flew left forward.

    Next, with MP we manualy entered the home position and redid the test. Same result. Can't figure this one out.

This reply was deleted.