• Setup sitl on Windows 7. Followed the recipe in the web documentation. Cygwin working fine. Mavproxy installed without errors. Python installed. jbsim installed properly. Built the sitl versions of ArduPlane and ArduCopter sucessfully without errors. Ticks to everything.

    When I run Mavproxy from the supplied script I get a graphic with no aircraft icon on it, neither plane nor copter.

    If I run the plane Mavproxy crashes complaining about non-existent parameters. thereafter the console is mostly unresponsive. I cannot exit the console. Enter key works. The console prompt remains at "initializing". There is no plane icon on the graphic.

    If I run the copter Mavproxy does not crash. The console prompt stays at "stabilized". Commands appear to be recognized but the mode does not change and nothing happens. There is no copter icon on the graphic.

    The web documentation is also incorrect. It states the command is -j4 --map. There is no there is a script called which works. What other errors are in the documentation?

    I've wasted a day on this. That's enough. I have research to get on with. Pity, I could have made good use of the simulation capability.

    If you have a solution let me know.

  • Hi I've added the line to .bashrc as specified in the new page at

    Now when I cd in ardupilot/ArduCopter and then try running

    make sitl -j4  and I've also tried it without the -j4

    I'm getting the SKETCHBOOK not found error:

    ../mk/ *** ERROR: cannot determine sketchbook location - please specify on the commandline with SKETCHBOOK=<path>.  Stop.

    I cloned it off GitHub and have followed the instructions so far as given. 

    I have no idea what to do and any help is appreciated.


  • Hi guys!

    Could anyone help me with building arducopter?

    the build fails just after "Copying fixed headers" message with recipe for target '/tmp/' failed

    there is a same posts on the forum:
    but without answer.

    Thank you!

    • Developer


      I'd recommend removing the "-j4" from the make.  I'm not sure that will fix it as personally I always run SITL from within a virtual Ubuntu machine on my windows box.

      • No, this doesn't works.

        Will try to setup ubuntu VM

  • Dear Randy,

    This is Anh from Seoul, Korea

    Can I ask you about SITL for drone simulation?

    Recently, I try to use this tool on window 7, I am focusing on FLIP Mode for my quadcopter, but when I typed the command "mode flip", the simulation does not response(Please see attached file)

    So, can you tell me how to check this function on SITL?

    Thank you very much for your time


    • Developer


      Maybe you figured this out, but the issue is that flip mode can only be initiated from stabilize mode.  If you have a peek at control_flip.cpp's flip_init() function you'll see the check in there.  You could potentially remove that and see how it goes but I think that flip currently relies on the pilot's input throttle as it's base throttle for the maneuver.  A better way to do it would be to use the output throttle (i.e. motors.get_throttle()).  If that was done then it might be possible to remove the check from flip_init().

      Sorry for taking a month to answer!

  • Hey everyone,

    Does anyone know how to get wind to work correctly? Whenever I try to pass in wind from into It initializes to a value of zero. 

  • Hello to everyone,

    Thank you for all your suggestions. I managed to get the SITL simulation running for ArduPlane on Linux and I was also able to connect to the Mission Planner on Windows. Now I would like to view the simulation on Flight Gear using the Rascal RC (running on Windows) but I don't seem to be able to get Flight Gear to read the commands sent by the autopilot simulation. On the Mission Planner in the Simulation Tab I can see that Plane GPS, Plane IMU and Autopilot Status get some readings, however, ArduPilot Output doesn't read anything and the Rascal RC on Fight Gear doesn't move at all. I am using the system.fgfsrc ( file to start FG.

    Something that may be worth noticing is that I have full control of the Rascal RC in the begging before clicking in "Sim Link Start/Stop". Once the link is started I can not control the airplane anymore and it also doesn't move at all.

    Also, where is the Flight Dynamics model that the Simulator reads? I would like to edit it or create my own using JSBsim.

    Thank you!
  • I have followed the steps on both of the SITL on windows and SITL on linux wiki pages and now i can get up and running in my ubuntu VM.
    But i can't connect it to mission planner on my windows host.
    If I try to connect with UDP, it just says waiting for UDP forever.
    When I connect with TCP I can't get the MAVlink heartbeat.

    can anyone help me fix this please. Thank you very much.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25