A few comments on how to make the wiki clearer on how to set up Failsafe, and a question on how to test it. Extract from the wiki with my comments:

 

If you have enabled failsafe (how? I have set my config THR_FAILSAFE to 1 - is that correct?), your copter will RTL back to home, and auto-land after 20 seconds.

To enter failsafe, you must be armed (failsafe does not work when disarmed) and you must set your receiver to output a low throttle signal (below 975µs by default). To send a throttle value that is below your radio's normal neutral throttle value (say 1100), please read your radio's programming manual.

I would make this a bit clearer. For instance, "you must set your receiver to output a low throttle signal (below 975µs by default). This can be done by looking at the Status or Raw Sensor View (Radio) and changing the end point on your low throttle setting so that it is below 975µs. Then programme that into your receiver as a Failsafe setting (refer to your receiver's manual). Then reset your low throttle setting back to what it was e.g. 1100. Test that the receiver Failsafe setting is working by viewing the radio data as above and then switching off your Tx. The Ch 3 setting should now drop to the below 975µs setting. Switching the Tx back on should restore the Ch 3 setting to your normal neutral throttle value. Recalibrate your radio settings once you have completed this exercise.


How do I safely test that this will work? I tried taking my copter outside, powering it up, getting a GPS lock and then arming it and looking in Mission Planner. I could see Ch3 in reducing to 965 when I turned my Tx off, but there was no indication of a change in mode. Oddly enough, I am reluctant to turn my Tx off when I am flying it.

Any guidance on this would be much appreciated as I would like to have this safety feature as insurance to help prevent injury (and crashes and money!).

Regards, Bill

Views: 8428

Reply to This

Replies to This Discussion

Bill, I am glad you started this thread. Lets keep it up until we got things working as supposed and associated wiki correct and easy to follow. Failsafe logic is a critical safety feature that must work reliably and predictable.

Regarding your latest attempt, I think it depends on the WP radius parameter value, and current GPS position (which can differ by x meters from true position, as we know). So maybe it cannot be ruled out that your copter actually thought it was home and thereby went into auto crash mode, as described by Marco. Then again, maybe not. I intend to do some outdoor tests today that may shed some light on this.

Regarding the failsafe throttle threashold (975us), as long as your RX really output below 975us, the failsafe logic should be triggered. Its a digital logic, so 974us should trigger positively. But I agree that a certain margin is recommendable for variations caused by circuit design. 964us should be enough, but I have set it towards 930us.

During yesterdays slightly frustrating bench tests, at least I was able to determine that the failsafe logic does kick in when 975us thr threshold is triggered.

  • One indicator is the MSG FS OFF 1464 debug message (in the second window that opens in Mission Planner), as displayed in one of my recent posts.
  • Another indicator is the FS  flight mode discrimination logic; When FS triggered during any AUTO mode, copter stays uninterrupted in that AUTO mode. While triggering FS during a manual mode, motors are shut off. This discrimination logic is supposed to be determined by THR_FS_ACTION parameter. But it isn´t. The THR_FS_ACTION has no effect. (issue filed by Rui, though not as a FW bug but as a wiki error).


Don Brooks reports has got it working fine (on a APM1) in simulations. 

I would really love some more real flight reports about how members got their FS working.


If there is development work in progress concerning failsafe functionality (fixing possible bugs) then I expect that to be clearly announced, stating what currently does not work reliably and what should be expected at next FW release. Thereby saving days of pointless testing (and possible crashes) for people like us trying to understand what they are doing wrong...

Tomas, checked my parameters, WP_RADIUS is 2, so I doubt that it thought it was home. I will have another go when the snow has gone (the last time I tried and it flipped over in the field, I had snow get into my electronics, which I think caused problems later as I had another crash on the next flight)

I think that the throttle should be setup to something at least close to hover at the time that you bind. I believe all radio settings are accounted for and I think the Arducopter code needs to know at least an approximation of hover to be successful in RTL. Can someone verify that is true ?

I do have the THR_FAILSAFE at 1 to active it and THR_FS_ACTION at 2 so it will active RTL, but Ive not set up the radio yet to get it to work. Ill play around with it tomorrow.

What I do notice though, in raw sensor radio when I turn of the tx, the throttle goes up to full and all the motors outputs do as well. So in theory the quad would take of into oblivion.

Hi guys,

After a few flights, yesterday and this evening, I conclude my findings, having used FW2.3 GIT, APM2, MP 1.1.34  

I have programmed my RX to freeze all outputs except throttle channel, in case of failsafe. And the throttle channel goes 940 us, to trigger AC failsafe.

In short, FS function only works partly.

THR_FAILSAFE_ACTION value 1 or 2 makes no difference (BUG!).

For both values applies:

When flying a mission in AUTO and turning transmitter off, the copter goes RTL and finishes with automatic landing. In other words, it aborts ongoing AUTO mission and goes home.

When hand holding copter well away from HOME, Stabilize mode at hover throttle, and shutting off transmitter, motors stop immediately. That would be free fall, happening in flight. (BUG!)

When doing the same while hand holding in LOITER, motors do not shut down, but there is a significant decrease in thrust, feels like it would sink rapidly. Seems unreliable.

Same when shutting off TX while in RTL. 

I will file an issue on this.

Tomas, please report the problem in the issues section, cool thanks!

Done!  :-)

in my simple logic (that's all i got to work with : p) i would say set your receiver fail safe to activate RTL .to test maybe pull the props off and walk away and turn off trans and watch your telemetry to see if it switches to RTL you could do this while its hooked up to usb... just a thought

Found a break missing in a switch statement. Should be all working in next revision. Made the update to the Wiki.

Jason

I confirm Tomas, tested now a and is ok in the incoming 2.3.1, thanks for your report.

Thanks for quick response to the issue Jason!

Thanks for testing, Marco.

Tomas

Jason, that's great, thanks. Regards, Bill

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service