i have a problem setting up my telemetry. the problem is that tey not communicate each other. when i load settings the local version is SiK 1.9 on HM-TRP and my remote version is SiK 1.7on HM-TRP. is this the problem? the different versions between rx and tx! were i can dowload a SiK firmware 1.7 to downgrade for my local part!! decause i don't have a ftdi usb!!! please help me i am stuck

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • hope this solves your problem

    3DR sik 1.7

    I cant get my ground module to connect to the air module see my video

    • Hello, 

      Just wanted to let you guys know I solved my problem I had with 3dr telemetry. The original firmware I had was 1.9. I solved my problem by flashing 1.7 on both sides. Now it works just fine. If you have such issues where the remote side won't talk to the ground side feel free to flash the firmware. I hope this helps.

      • Hi all!

          The link of Theo is the 1.6 version, anybody has the 1,7 please? I need it and I can´t found it!

          Thanks a lot


    • I'm afraid that this is not different FW problem.

      Check if both nodes have same config.

  • I have 1.9 on local and 1.7 on several remotes and they communicate corerectly. Di you have the Net ID and all other parameters set the same on remote and local? If not that's the problem.



    BTW have you seen a revision history anywhere? I would like to know the differences between verstions.





This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25