Spectacular Crash

My Quad is a Basic uDrones Quad with Sonar. (No Telemetry, No OSD, No Camera Mount)

Well I've been having a blast flying my Quad and getting better every time I fly. One of my goals to be able to fly around a friends house and take pictures of it for her. But I want it to look good, so I've been practicing on my flight skills. Now I've crashed a number of times and broken a few props in the process. So I figured it was time I used the flight planner to try and automatic my flights. I read the online docs, which were a bit outdated, but I figured out stuff. I've been getting up early everyday this week and flying while the winds were calm in a field next to my work. I was able to fly a few flight plans, but the results were not what I thought I should be getting. To be honest when I invoked the Auto switch it was pretty freaky to see my Quad fly like a bat out of hell. I normally try to fly level and move around slow and easy.  But in Auto mode my Quad was a beast on steroids, it tilted over a good 30% and was flying mad fast.

I was using the Auto Way Point option and had Created WP Circle (see below). I also wanted the Yaw Angle to change, hopefully use this to point a camera at a center point. I also reduced my altitude and reduce the number of way points. (I've attached my flight plan for review)


Below is the Google Earth flight of my log. As I stated, my Quad flew crazy fast and by the time it hit the tree I was stunned. It ended up in the street by the field, with 2 motors hanging by their wires with bent shafts and frame stack broken and my GoPro camera laying in the street with it's SD card ejected. All the props are shot. Still trying to figure out how to get my video to play from the GoPro. Lucky the APM was OK and frame looks OK. I figure it's going to cost about $75 to fix, parts are on order and I hope to have my Quad back in the sky sometime next week.


OK, now for some questions:

  1. Can I slow down the flight of Quad while it flies my flight plan?

  2. What happens at the end of flight plan if it ends at a way point? (Should I use Return to Launch or Land at the end of flight?)

  3. What does the Delay and Hit Rad options in the Way Point do?  Is it safe to assume that the Yaw Ang option is direction the Quad points on the compass?  Does the Yaw Ang hold until changed again?

  4. How do I tell how high my Quad is flying?

  5. Should I be able to replay my flight from within the Flight Data screen? I've tried to load my logs and play them, but the display doesn’t seem to change. Is this because I don't have a telemetry module?

  6. I seem to have troubles getting my USB to connect with the APM. Is there some kind of steps I should take to get it to connect? Normally I just connect the USB cable and I keep clicking the connect button in the top right corner. Sometimes I get an error, then I pull the USB cable and re-launch the Mission Planner application. It just seems to be a hit or miss process. I'm running XP SP3 within VMware fusion.

  7. Anybody had any success recovering a video from GoPro camera? There are online services, but they want $40 and though I'd like to see the video, it's not worth $40. I tried a Perl Script called FixenV2 (http://goprohacks.blogspot.com/p/how-to-restore-gopro-mp4-corrupted-or.html), which looked like it might work, but the video it recovered was all black.

I'd like to thank all the people working on DIY Drones. You guys rock!

Richard Boyhan

TOD Town Hall Field Test3.txt

2012-08-23 19-18 3.log

2012-08-23 19-18 3.kmz

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Richard,

    As for your question 5, you can load and look at parameters of your flash log file using the tools built into the CLI of mission planner, click on the "log browse", however, I suggest you use my program, APMLogVisualizer version 1.34, it is pretty easy to use, and very informative:

    You can get it here:


    I'm currently looking at your log file using APMLogVisualizer, so far I've found a couple of things:

    17:33:43.25 your GPS had a couple of "Hiccup Readings"  This caused the copter to jerk a bit, but this was while heading to waypoint 4.  I've seen this on my copter as well, I don't think there's anything you can do about it, sometimes it just happens.  Maybe the more expensive GPS would do better.

    OK, problems start right after it finished WP6:

    It finished WP6 and Started WP7 at 17:33:52.49

    At your time 17:33:52.75 all was still well,

    but at 17:33:53.00 all heck broke loose.

    I'm glad you logged your motor outputs.  Most folks don't and it makes it harder to figure out.

    But I do need to know if you're running the + or the X configuration.

    At first glance, I'd say an esc/motor/propeller/wiring failed on one of the motors, but I should be able to figure it out when I hear back about your configuration.

    Dan Gray

  • Someone told me your waypoint radius needs to be 30.

This reply was deleted.


David Hori liked Isabella Domi's profile
Jan 12