Switching to alt Hold or loiter cut off my motors.

3691070646?profile=original

Hey,

i running apm2.6 with latest "stable" 3.0.1 firmware. I use latest  MP 1.2.83 to make my settings. In moment my copter fly very stable in stabilised mode. Today i decide to test other flight modes. At first i tried AltHold. Switching into this mode nearly cut off my motors. See graph on top. Of course i have corrected the THR_MID parameter as shown on the ardurcopter homepage. My value here currently is at 428 for 6kg take-off weight.

Some words about the copter. It is a hexa for heavy playload. Today the take-off weight was 6kg. max  take-off weigh is 8kg and min is 4,5kg. Currently I have mounted 6 t-motor 4012-400 with 15x5 carbon props at 6s(22.6v).

I have less vibrations on apm and gps/compas module because motors and props are very balanced. The Apm is mounted with all other electronics on a separate rubber isolated layer. Also this layer hold the separate battery for powering the apm and other electronics. this mean this layer brings a lot of mass against the mainframe with their heavy main batteries, motor mounts and esc s. This is generally god against vibrations.

My accel log:

simple hovering is between 70 and 90 seconds in log file. all other is starting landing and some throttle tests.

3691070805?profile=original

So i try to find the problem in main settings. And here especially for THR_ALT_I / P.

MP defaults and currently unchanged settings for THR_ALT_P and THR_ALT_I are

THR_ALT_P = 1.0

THR_ALT_I = 0.0 .

Did i have to change this setting? Is this the problem? Currently i am unsure because the wiki only talk about 2.x firmwares. http://code.google.com/p/arducopter/wiki/AC2_AltHoldMode

greetings wolke

alt-hod-cut.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The same happened to me, and I solved it reducing the LOITER PID to 0,5 as Randy recommended in the 3.0.1 post :

    ''Warning #2: GPS glitches can cause sudden and aggressive position changes while in loiter mode.  You may wish to reduce the Loiter PID P to 0.5 (from 1.0) to reduce aggressiveness (see image below of where this gain can be found in mission planner).''


  • hey :(,

    second alt hold test today. same result:(.

    testflight:

    • starting in stabilised mode and climbing to 20 meters hight
    • hovering stable at 20 meters. throttle stick is ~47%
    • switching to alt_hold mode
    • motors nearly cut of and copter  fall around 6-10 meters
    • quickly switching back to stabilised mode and throttle up to hold the copter

    while the copter was falling i noticed no changes in throttle. the props nearly stops during the period as alt hold was switched.

    in moment all settings for throttle are default values. i really need some help here because i do not really understand the instructions and/or the background theory behind for tuning this values. http://copter.ardupilot.com/wiki/altholdmode/#Tuning

    greetings and thx in advanced

    wolke

  • Wolke

    The same is happening to me - see my recent posting 'motors cutting out when testing'.

    I have been upgrading firmware for years and have the latest MP 1.2.83 and am trying -r4.

    I never had this problem with"stable" 3.0.1 firmware.

    Maybe it is some setting in MP 1.2.83 ??????????

    If I switch back from either Alt hold or Loiter to Stabilize then all seems OK????

    Not game to fly until this is resolved

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…