Tarot 2D gimbal and Pixhawk - Tilt control

Hi everyone,After spending almost my entire Sunday trying to get this work, I finally thought that asking here might be wise...Here is my problem:I can't get to control my tarot gimbal tilt from my RC through the Pixhawk.I think the Pixhawk is running the latest apm version (I updated it a month ago).I've found two different wiring instructions.- Here, using 3 cables: http://3drobotics.com/wp-content/uploads/2014/02/Tarot-gimbal-kit-quady6x8.pdf- Here, with 2 cables: http://copter.ardupilot.com/wiki/common-tarot-gimbal/None would work for me.With the 3 wires option, the gimbal turns and locks facing up/left.With the 2 wires option, the gimbal behaves like it's working independently (i.e. stabilizes nicely, keeping the camera straight, but now way to command it).I checked in APM PLANNER, RC calibration, the knob (pot) I want to use seems correctly mixed to channel 6 and I can see the gauge moving on the calibration page.So it seems that it is not something on the RC side or the Rx.Btw, I use a turnigy 9x flashed with the er9x firmware. The receiver is a FrSky D8r-II plus flashed with the XP firmware to get PPM.I also followed the wiki instructions to configure the gimbal in the mission planner.I uploaded the 3dr settings to the gimbal with the tarot flashing software.And the gimbal is running the 1.4 firmware.So please, can anyone help me find where I'm messing up?And as a starting point: is it a 2 or 3 cables wiring needed to the pixhawk?Many thanks for your help,Mathieu

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hello all:

    I had the same problem using an Alexmos type gimball and finally got the following solution:

    - Connected Main Out nº6 (section 3) 3702444495?profile=originalwith gimball

    - Set SERVO6_FUNCTION to 1 RC PASSTHU ( http://ardupilot.org/copter/docs/parameters.html#servo6-parameters )

    Be sure to power the Pixhawk with battery when testing (not through USB)

    Complete Parameter List — Copter documentation
  • Hi All,

    I am having the same issues that I am not able to operate my Tarot 2-D gimbal through RC.

    Here are more details about my systems and things I've tried so far.

    1. Pixhawk with Arducopter V3.3.3, 

    2. S900 airframe

    3. Followed all the instructions given here , http://ardupilot.org/copter/docs/common-tarot-gimbal.html

    4. Tarot 2-D gimbal with Gopro 4, latest firmware flashed

    5. Output rail powered via separate BEC (although not necessary since Gimbal is powered on it's own)

    Gimbal operations; It maintains preset attitude (GoPro camera orientation) pretty well, flight tested.

    My goal;

    I am trying to get the manual control of camera via RC working but no luck so far,

    I have tested the toggle option via Mission planner and Gimbal moves fine but when I try to operate via Transmitter the gimbal doesn't work.

    What am I doing wrong ? any suggestions ?

    Tarot Gimbal — Copter documentation
  • I got this to work on a pixhawk to tarrot 2d gimbal. I can't get the ROI to work but the knob controls the gimbal. I had to use channel 7 or 8 and it wired up to the second row of pins on the pixhawk. I'll hook her up later and get the exact settings for you.

    • 3702517653?profile=original

      • black and white wire only

  • I'm having similar problems controlling tilt on my Tarot-2D, and at a loss of what to try next.

    Here's what I've done so far:

    1. Followed all the instructions on the wiki
    2. Verified that Signal (AUX 1 / RC9 on the Pixhawk) and ground are in the right places, and that I'm connected to the minus and "T" pins on the Tarot.
    3. Verified correct configuration on Tarot (V1.5, Tarot Mount, Standard Receiver, Stick Position Mode)
    4. Verified calibration on radio input channel (RC7) - channel mapping and limits.
    5. Verified Camera Gimbal settings in APM  

    The "blinking blue light" indicates a connection on the Tarot, and it stabilizes fine.  I'm actually able to successfully change the tilt on the gimbal if I change the Min/Max Servo limits or the angle limits (although I can't exactly determine the correlation).  

    However, I can't get it to respond to the AUX2 knob on my Spektrum DX7s controller.

    If I connect to the port on the Tarot, I'm able to see a change in RC input.

    I've even tried the other AUX outs on the PIXHAWK, adjusting the appriate settings in APM, and verifying that it is indeed talking to the right channel.

    Perhaps something is fried? Errant APM parameter not set right?

    At a loss of what to try next.

    • Hi Chris,
      Make sure you calibrated the gimbal sensor in the Tarot software (back of the camera mount laid on a flat surface, camera facing up) and see if it works.
      I think this is what unlocked everything for me.

      Good luck!
      Keep us posted :)
      Mathieu
      • Hi,

        Is it just the calibrate button, in the software after facing camera up?

        Is it OK if camera is level & facing up whilst installed on the quad or does it have to be on a table?

        My tarot just flashes blue & does nothing.

        When usb plugged in, shows on screen & image changes as I manually move the camera.

        Thanks in advance.

        • So far as I can tell, this is all that needs to be done.  You can "enable motors" to see it point straight and level, and perhaps you may need to "save settings to flash" after done.

          • Cheers,

            Should the unit level with power on even if other wires (plugged into Pixhawk) are wrong or not plugged in at all?

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…