Why are motors not getting full power from arducopter

Arducopter is limiting the total power output of my hexacopter to 37 amps when it has the potential for 66amps when at full throttle.

I bench tested many different motor and prop combinations to see which would be the most efficient for my arducopter hex 550.

I decided to use 6 x 1000kv motors with 9x4.7 props which deliver 710g of thrust at 11amps each at max throttle.

Why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.  (see mission planner tuning chart)

I understand that the controller needs reserve power for controlling stablization but 37 amps is only 56% of total power potential that could be used.

I have calibrated my escs many times thinking that was the problem but its not.

When i use my kk2 controller on the same hexacopter i get 52 amp draw at max throttle held down on the bench.

Is there a setting that i need to change to allow the controller to use more potential power.

I want to put more equipment on this craft but it needs more power.

Thanks in advance for your help.

the Chart below shows thrust output for each motor/ prop combination.

I decided to use a 1000kv motor with a 9x 4.7 prop. next chart

3690986315?profile=originalThis chart is just the 1000 kv motor with 9x4.7 prop  

max thrust was 710 grams at 11amps

3690986145?profile=originalI went into the tuning page for Misson planner and see that at full throttle i am only drawing 37 amps for 6 motors.  Hexacopter held down at full throttle on the bench while connected to MP.  the hex draws about 25 amps at hover with no extra equipment on board.

3690986336?profile=original

why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.

I understand that the controller needs reserve power for controlling stablization but that is only 56% of total power potential that could be used.

Is there a setting that i need to change to allow the controller to use more potential power.

3690986291?profile=original

3690986349?profile=original

2013-01-12 08-43-58.tlog

2013-01-13 16-39-04 tethered to pc flying hex.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Replies

        • I thought of the exact same fix but be aware that it could result in an unstable platform and eventually a crash. Maybe it would be smarter to calibrate at around 1900 or something so the FC still has some power margins of correction if you are at full throttle. You might also need to look over your PID's as the output will mean more respons now.

      • Trying my old multiwii the platform works really nice!.. I will go up to 4S batteri to be able to run APM, think it will do the trick.

  • It could also be that multicolor is too heavy for the propellers/motors combination.  You might need bigger props or higher pitch or both. 

    I have a quad with 850kv motors and 11x5 props, 50cm motor to motor and it weighs 1300g all upp weight. It flies nicely. But I tried adding 500g and it felt much havier, still could lift but was not fun flying it. 

  • I wonder how come none from the developer team or senior members of the forum did not notice this or other posts related to this problem. Thankfully there are other posts helping on this.

    Anyhow, I think the answer can be found in this post http://diydrones.com/forum/topics/arducopter-thrust-problem?id=7058...

    To summarize APM was reducing the throttle somehow and manual ESC calibration (described here http://copter.ardupilot.com/wiki/initial-setup/esc-motor/#Manual_ES...) seem to solve the issue. 

    My worries is that why does APM reduces the APM purposfully or is this just an error?

    How about the others, has anyone solved this in some other way?

  • I just finished assembling a build, and I'm having the same issue.

    I haven't been able to try going to an older firmware, but I don't understand how this could be the way to fix this.  There has to be a setting somewhere.  I have tried adjusting the mid throttle setting, as well as making sure the throttle pwm is set at 1000-2000.  This has not worked.  I do know mathematically my system checks out, although slightly under powered in my opinion and to some extent was out of my control at the moment.  I do plan on upgrading later to make the system more efficient.

    Frame: hexarotor

    Propellers: APC 10x3.8SF

    Motor: Scorpion SII-3020-890KV

    Total Max Thrust Available: 8580grams

    Bottoms Up Weight: 4614grams

    Thrust to Weigh Ratio: 1.86

    From testing static thrust, I was able to run the motors and obtain about 1430 grams of thrust while running at about 23 amps. In theory, this means if all motors spun at max rpm, it would run at 138 amps (I realize you have to leave room for maneuvering).  When trying to fly, I am only seeing about 80 amps.  In other words, I'm using about 57% of the maximum throttle I could.  My use for the system does not require it to move around much, so I would be completely fine with it pulling 70% just in order to hover. I plan to change this though in order to decrease power consumption in later iterations. I should add that I haven't been able to get out of ground effect.  Just not enough power

    If anyone has figured out more on a solution I would love to hear about it.

    Thanks!

    • hi, 

      did you fine a solution, i ve got the same problem, i need 10% more power, when i graph my throttle input and throttle output, apm is applying a coefficient.

      i tried calibrating esc one by one without apm.

      i tried putting a higher value on param thr_max but it only increase the thr_in

      i tried tricking apm calibration of my radio by playing with trim.

      my setup could work at max 20 amp but at full throttle i never get under 5 amps

      i attached my thrin out log, on the first one its on hover, on the second one its from min to max.

      it s not a problem in stabilize to have thr out hover at 750 (ie thr mid) but in alot hold or loiter i can t put enough throttle in case of fast descent.

      3702474557?profile=original

      thx3702474469?profile=original

  • What you have is a simple enough setup, I have one myself.

    Reading through your post, and the replies, I can see no mention of doing an erase/reset after a firmware upload.

    Have you done these?

    The reason I ask is because the PID values do not look right in the screen shot you provided (early firmware I know).

    Another question - have you enabled IMU logging and had a look at the amount of vibration on the accels.

    You provide tlog but no .log from the APM.

    It's just that you mentioned unstable alt hold, and excess vibration will cause that from 2.9 firmware onwards.

  • Luis, had to go out of town for the day n. Postponed the testing to tomorrow. Appreciate the links! More when I get back to my computer
    Keith
  • I have a similar problem.  I've got a tricopter with 3 .10 size electric motors that can cruise at 50 amps.  Current use at WOT is only 22A with a fresh battery --using my 60 amp ESCs.  That's less than 50%.  I tried adjusting the transmitter range as well as fiddling with the MP Radio calibration range with no positive results.  One thing I did just for grins, I put my Turnigy 70A ESC on the same motor and unexpectedly it is pulling 30A, now .  I'm not sure I understand why the motors aren't spooling up properly and definitely not sure why the 70 A esc added 10A to the top end over the  60A ESC.  So if I go to a 90A esc is the motor going to pull 50A?  I was under the impression that the motor limited the current coming from the ESC.  I set the range on both ESCs per the mfg instructions.  Any suggestions are appreciated.

  • I too am having this same problem.  From the ESC calibration mode, i get 33 amps at full throttle (tri copter).  Through the APM at full throttle, i only get 15-16 amps.  Roughly half.  What gives?

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…