Windows 7 64bit and ConfigTool 1.4.14TDI

Hi,

I'm sure I'm going to feel like a mug for asking this, but I can't get the config tool to run in windows7.  I've installed the Remzibi OSD tools and .Net Framework 4, but the config tool is still not showing any maps.  Windows throws up a dialogue box when i close the tool saying "this tool needs Flash.ocx" which is not included in this operating system (see attached screenshot of the error).  I've uninstalled and reinstalled flash, but that does not improve the situation.

thanks
Jim

win7_configtool_err.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Glad to hear you guys got it working. Flash for 64-bit only came out 3 days ago (I think)...so the solution hasn't been around long....
  • Hi HK, great finding... as always helping with your good investigations. Glad to know that this was an issue with Flash installation and not a bug in the GCS.
    I have a Windows XP just to use the GCS but now will try in my Windows 7 to see if that works fine.

    Thanks,
    Leonardo
  • Jim, try installing the 64-bit flash player

    http://labs.adobe.com/technologies/flashplayer10/
  • Jim, here's something else to try (cut and paste from another forum)

    "Double click on My Computer on your desktop, then click Local Disk C, then click Windows, then System32 Folder. In the System32 folder look for the Macromed folder. Click on it, then right-click on flash9.ocx. Click on Copy, then left click and select Paste. Now right click on that copied file and rename the file to flash.ocx Do not delete the original flash9.ocx file.
    That should fix the problem. "

    They are suggesting locating the file flash9.ocx or flash9b.ocx in \windows\system32\macromed\flash or C:\Windows\SysWOW64\Macromed\Flash, make a copy and rename the copy to flash.ocx (don't delete the original file). It seems to have fixed a bunch of people's same issue in 2007. I can't say it will fix you Windows 7 64-bit issue.

    http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=...
  • I'm afraid this is over my head. 64-bit OS's seems to be a cluster at this point because nothing is written to run on them and I guess Microsoft is ok with that. I can't even tell you the difference in directory structure. Who knows, does it have a different directory for 32-bit or is that completely unsupported? I know on a 64-bit Vista I used I was able to run XP is a virtual machine and get 16 and 32 bit apps to run. Does Windows 7 have the same?
  • I have no clue if this fix will work, but here's the Flash Folder from my PC. I wouldn't overwrite any existing files and you'll need to register the OCX's and DLL's (using regsvr.exe)

    http://www.happykillmore.com/Software/RemzibiOSD/GettingStarted/Fla...

    It came from my C:\WINDOWS\system32\Macromed\Flash folder

    Again, don't overwrite anything.
  • The only issues I've experienced with Google Maps have been old versions of .NET and old versions of IE. Typically these reports were from users running FireFox and refusing to run any IE updates because they don't use/want IE.

    Here's a troubleshooting guide for Google Maps

    http://maps.google.com/support/bin/topic.py?topic=10781

    http://maps.google.com/support/bin/answer.py?hl=en&answer=21849
  • Try this version of the exe: http://www.happykillmore.com/Software/RemzibiOSD/GettingStarted/Ard...

    I tried these directions: http://stackoverflow.com/questions/1415352/flash-ocx-class-not-regi...
    but I can't test it.

    PS, this is v1.3... to do this with 1.4, click Project, Properties and on the Build tab change platform target to x86.
  • 3D Robotics
    Do you mean the ArduPilot config tool? It works fine with 64-bit Win7--I use that combo every week.
  • You generally will see that error when you do not have the proper flash player installed or the program is looking for an older version of it. Do you happen to be on a 64 bit win7 because from what I remember flash player can only run in 32 bit mode

    Another thing to try is browse to
    C:/Windows/System32/Macromedia/Flash and look for flash10c.ocx or flash9c.ocx and copy and rename to flash.ocx

    Hope this helps and hope I am on the right track with my suggestions, its the best I can remember right now with no windows box in front of me.

    Oh and you installed google earth as well right :)
This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Wednesday
gotham liked gotham's profile
Dec 3, 2020
More…