Wire raspberry pi to pixhawk

Hi I have been following the raspberry pi to pixhawk connection using mavlink tutorial on ardupilot. I am using a raspberry pi 3. When I did the last step(ttys0) for connecting the mavlink I get stuck at waiting for heartbeat. I checked online and followed solutions but none have worked. So I have come to the conclusion that something is wrong in the wiring of the raspberry pi to the telemetry 2 port. Our wiring is correct but the wires are loosely connected as we do not know what to use for connecting the telemetry 2 jumper cable to the gpio pins. So my question is how and what do we use for connecting telemetry 2 port to raspberry pi gpio pins(like solder or is there something else) and how do I get past the waiting for heartbeat in the mavlink? Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • you can connect rasp pi with pixhawk via telemery port. and i have hardware for make it easy!




    XBStation 4G Drone Solution
    Solution for live streaming video and control UAV via 4G LTE
  • Hey, the project ended about two months ago and we ended up dropping the pi 3. So we still have no idea how to get it to work. I checked the pixhawk website and the only supported companion computers from raps very pi series was the pi 2. So you'll probably have better luck with the pi 2. And about the baud rate, if you plug your pixhawk into your computer and run mission planner you should be able to find it in the parameter list. Sorry I couldn't be of much help, good luck with your project!
  • Hi there,

    im wondering if you have had any luck with your problem? i am also using pi3 + pixhawk (using the above recommended cable with the wires swapped as per the ardupilot guide), serial ports are off. im getting almost the exact same thing as you although i dont get "Waiting for heartbeat" just "MAV>"  entering commands like "param show ARMING CHECK" does nothing... just gives me back "MAV>"

    by the way how do check the baud rate on the pixhawk? pretty sure its set to 57600 but i wanted to check.

    hope you dont mind me joining in but i figured if were running the same companion computer and having the same issues we might be able to help eachother out!

  • Yes I still get the same problem. I have even tried it using two linked telemetry radios. All I get is 

    pi@raspberrypi:~ $ sudo -s

    root@raspberrypi:/home/pi# mavproxy.py --master=/dev/serial0 --baudrate 57600 --aircraft MyCopter

    Connect /dev/serial0 source_system=255

    no script MyCopter/mavinit.scr

    Log Directory: MyCopter/logs/2016-04-30/flight20

    Telemetry log: MyCopter/logs/2016-04-30/flight20/flight.tlog

    MAV> Waiting for heartbeat from /dev/serial0

  • Yes. The camera, ssh, Inc are all enabled but the others are all disabled
    • I have tried adding core_freq=250 as well as trying ttyAMA0,and ttyS0 and serial0 and they all get waiting for heartbeat
  • Yes, both are set to 57600
This reply was deleted.