Xplane simulation does not work on newer firmwares

I can not get newer firmwares then 2.7 in hil mode to work with xplane. I can run a simulation fine using older firmware but not with newer firmware as i want to test out geofencing that is not in the older firmware.

With the newer firmware there is no control what so ever and if i go back to older firmware such as 2.7 it works fine

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am using xplane 10. APM 2.6 MP 1.3.21 on the same PC. I tried yesterday all vintages of HIL firmware

    I have added the info required to get the simulator work and get the following error message

    I do not get any data in the simulator

    I have never been able to calibrate the RC radio after uploading the HIL firmware so I reload a calibrated param file. RC calibration works fine in the normal flight firmware

    Help please this is driving me nuts

    3691192919?profile=original

    • @Maxwell--I see it's been about a month since your post.  I hope you found a resolution.  After a year-long hiatus, I'm getting back into my ArduPilot (2.0 in my case).  I'm a big fan of HIL simulation, but it always seems to have one issue or another.  I went ahead and updated MP and APM firmware and then went into HIL mode.  In addition to other issues, I eventually got the same error in your post above.  It didn't happen at first, then after clearing up it came back again.  One of the other issues I'm having seems to be getting the gains right.  At first, my transmitter inputs had no apparent effect on the virtual plane control surfaces.   I finally got a decent response to transmitter inputs going through to X-Plane, but when I tried auto mode things did not work out well (gains had to be set all the way down to 600 as opposed to the 10000 default settings).  In any case, in auto mode APM seems to be attempting to control the plane, but it would eventually crash.  While the issue seems related to gains, I think something more fundamental is wrong--I just can't seem to put my finger on it.

      It's oddly reassuring to see that someone else is having issues.  If you were able to get things working, can you share the solution?

      Thanks,
      Paul

      P.S.--I also have the issue of not being able to calibrate the transmitter.  The ability to do so comes and goes.  I have had this same issue in the past.

  • Martin,  will try again, thank you. I think IP stuff OK - ..005 out 000 in etc.

  • Yes, I get data on all areas, but just the initialising red light flashing still!

    • The red light flashes on mine up to the point where I press the "Sim Link Start" button, then the sim screen fills with data and the red light changes to solid with a blue light next to it coming on solid too.

      Have you checked that you have the IP addresses in Advanced IP Settings in MP and on X-Planes correct.

  •  I can verify HIL is broken past AP 2.70 perhaps Google did something that broke it? Anyway I guess we need to open an issue.

    RM

    • How do you open an issue please? Is it something the site administrators get involved with, or what? I would very much like the HIL failure to be looked at/resolved ASAP.

      I am sure that we all appreciate the work done by the project teams, and hope they continue.

      Incidentally, is it possible to still download the 2.70 HIL Plane file - I'm not code-literate though,,,,,,

      • Hi Keith, I have the latest HIL version of Arduplane working on my PC right now with no issues, I'm using Windows 7and X-Plane 10. It is working with my arduflyer 2.5 clone board and my original APM1 too.

        I did have a problem with the more recent HIL versions, but Andrew Tridgell listed this as a fix on the latest version of Arduplane 3.1.0. :)

        • Martin thank you for your reply,

          When I look at the Firmware screen on 1.3.9 I see Plane as 3.1.0, but I also see HIL plane as 3.1.0 (without any HIL suffix)! Is this what you have please? I've tried it a few times, with the red APM light flashing only, then gone back to normal plane 3.1.0 where all is fine i.e GPS blue lock etc.

          I'm 2.6 with Win 7 and X-plane 10.

          Am I missing something here? 

          • Yes, when I select the HIL version of ArduPlane halfway down the Mission Planner "install firmware" page it reads "Are you sure you want to upload ArduPlane V3.1.0?" and I select yes.

            But you're correct it used to to say" are you sure you want to upload HIL ArduPlane Vxxx" I think that the HIL just got left off, but it works fine.

            Re the GPS flashing, when you use the HIL version the APM uses data fed back from the flight sim, and doesn't use the actual sensors at all, hence no GPS lock is required. so you don't need to calibrate the mag or set the plane level on start up either, like you do when you use the flying version of the code. 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
2 hours ago
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
2 hours ago
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
8 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…