Xplane Simulation keeps crashing into ground as soon as I enable Auto?

HITL stimulation used to work great a few versions back, but I recently tried to load the latest APM HITL 2.2 code and now as soon as I enable auto/ stabilise or anything similar my aircraft just spirals into the ground.

I then tried to update the mission planner to the latest version (1.0.54) and I still have the same problem, I then proceeded to update my xplane to the latest version 9.70, still the same problem.

I was looking at the ardupilot outputs on the mission planner, and when the aircraft was level on the ground, the ardupilot output was showing about -0.6 for the roll.

Any help would be appreciated

Views: 1344

Reply to This

Replies to This Discussion

Hi Alex,

I'm having the same problem.

The plane flyes really nicely on stabilize but it goes nuts and crashes into the ground in auto mode.

Some suggested to use Xbee instead of direct USB. That trick did not work for me as with XBee the system becomes extremely slow!

I can't take my plane for the maiden flight if the simulation doesn't work.

Any suggestions will be much appreciated.

Regards,

Adrian

 

Well i found that my problem was that If i did not connect my radio up to APM it did not work properly.  Also I would suggest updating your xplane , Ardupilot HIL firmware and mission planner to the latest versions.  As for your first flight, I would not worry too much if you know how to fly RC aircraft and using a plane you know how to fly you should be fine.

I have the same problem have loaded latest versions of all, all checks out and take of perfect all controls work well ontil i change to auto... carzy diving and ultimate crash

 

Regards

 

A.

I am having the same issue. I have updated to the current versions of everything and have tried previous versions of all the software as well. It seems to me that the ArduPilot defaults to max deflection of the control surfaces for some reason. It is very aggrevating and if anyone has any idea please let me know.

I have only just started with HIL simulation so take the following with a grain of salt :)

Actually, not all the posts in this thread describe the same problem. The following only applies to the situation where engaging ANY other mode than manual leads to immediate crash. (One poster only crashed in AUTO mode...)

If you watch closely you can see the plane flipping to inverted flight shortly before going into a death spiral. If that's your problem then try the following which did the trick for me:

Don't use the "Reverse Roll/Pitch/Rudder" checkboxes on the "Simulation" tab in MissionPlanner. Instead, use the servo reverse controls provided by your transmitter.

My HIL simulation too responds in a similar manner........works more or less ok in stabilize for about 2-3 minutes, after which it starts to descends steadily until it crashes to ground......for AUTO, the moment i switch mode it starts descending rapidly.........here's the XPlane trajectory for STABILIZE mode....

Interesting part: no change in throttle is reported either in XPlane or in sim tab of Mission Planner.....so throttle doesn't seem to change by itself.....

Finally got it to work...........the mistake was i had selected the "loc, velocity, distance travelled" values also in XPlane to be communicated to Mission Planner.......

Nice to see that its working with arduino mega 2560 board as well......

I am still having the same problem stated above.  In both AUTO and STABILIZE modes my plane descends towards the left side until it hits the ground. When its on the ground before takeoff, the outputs of the autopilot's roll, pitch, and yaw are not at 0. 

I do not have anything attached to the ardupilot except for the usb cable going to my laptop. Would the fact that I don't have an RC controller attached to my ardupilot cause problems?

Sure enough, as soon as I hooked up my radio controller receiver to the Ardupilot it began to work just fine.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service