Supported devices and connection problems

Let's put this in here so everyone can start to post reports and get their devices working. 

Tested and OK devices:

- Samsung Galaxy Note II (AND_4.1.2) - (19.02.13)

- Samsung Galaxy S3 (AND 4.1.1) - (19.02.13)

- Samsung SIII, (AND 4.1.2) -  (21.02.13)

HTC One X+ (AND 4.1.2) - (21.02.13)

Acer Iconia A500 (Thors ROM) - (28.02.13)

- T-PAD IS709C, (AND 4.0.3) - (03.03.13)

Motorloa Photon XT897 (AND 4.0.4) - (05.03.13)

- Samsung 8" Note (AND 4.1.2) - (25.04.13)

Asus TF300T and TF300TG


Tested but having problems:

- Oker TP-703 tablet (AND_4.1.1) - no link (19.02.13)

So if you have a device that you tested and it is working or not working, please post in here so we can update list, Please include your android OS version too.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Oukitel Original One O901 4.5 Inch Android 4.4 K78 Cell Phone MTK6582 Quad Core 512MB/4GB 3G WCDMA OTG

    But the GPS is not real so any mode requiring the phones gps won't work.


    This cheap 9" Chinese tablet works great with andropilot!!!  They also have a 7" I suspect it would work fine. Might have to get a utility app to turn on usb to 'host' mode for the 7" but I didn't need to do that with the 9". Gotta find the apk files outside of google play as the tablet does not support googleplay. Here's a direct link to the latest andropilot andropilot-2.0.01-market.apk Thanks Kevin. Note you need to find and install google play and googleplay services, They can be installed but they will not run. I guess they didn't want to pay the three headed monster google Inc a royalty fee. However it seems abdropilot needs to see those apps installed. The fact they don't work is beside the point. fyi this tablet does NOT come with an internal gps. It can work with a usb gps which would be useless as we need the usb for the telem module. Oh and another fyi this guy sells a really nice tablet holder that works well with some Futaba handles that are plastic or any other transmitter for that matter.


  • I am using PIPO Android Tab v 4.11. So far, i have done several flights using this tab.  Different modes were tested such as Guided, Waypoints, RTL, Disarm, Alt Hold, Acro, Land. This tab is working properly as it should. PIPO, by the way, is one of the cheapest Chinese made tab.

  • 7" Cheap Chinese called Xtreme tablet 7C Droid 4.0.4

    This tablet does not work with goggle play so download latest adropilot here Obviously then look in your downloads click and install 

    Also the tablet does not come with usb host mode on so,

     - Install "USB Host Check" from a place called Aptoide [ remember googleplay isn't supported]. Or any other app that sets the tablet in usb hoist mode.

     - Run the app and press Fix. All items should be with a green check.

     - Reboot tablet.

     - Connect 3DR with this

    If it doesn't work find googleplay and instal. It won't work but andropilot needs to see the app installed as I recall.

    Also... this is not the one I have but I bet it would work if you can set it in usb host mode the same way as above. Plus this one has google play so a bit less screwing around finding USB Host Check. 



    An android ground controller (and other things) for Mavlink/Arduplane - geeksville/arduleader
  • I got my Pipo S2 working in USB Host Mode with a 3DR Radio directly connected by flashing the rom here:

    and then downloading an app called 'usb host check', and then running the fix inside there which restores the missing files it needs for the USB host to work.

    Now to work on a nice mounting solution for it on my TX

  • Anyone had any luck connecting the new HTC one? I keep getting the error "USB device not supported".

    - I've tested my Microsoft wireless mouse, usb wired keyboard and they both connect and work fine...

    - Rooted the phone

    - Installed usb host check and ran the fix, re tested still not working!

    - Looked through previous post and saw someone recommending this:
    - Couldn't find these folders on my phone through the pc browser, do you need to browse from the command prompt? This is my first android phone...


  • Tablet that does not work:

    Amaze 7"

    Successfully connected a USB drive with my OTG cable and copied files off it.

    Connected my working 3DR radio up to my Amaze tablet and it would not connect. Lights came on the radio.

    Tested 3DR radio on my laptop just to be sure - worked fine

    Eventually sold it for $50 to a mate at work and bought a Google Nexus off eBay

    BTW it did not work in Droidplanner either.
  • Google Nexus 10: Nothing. Can't get the thing to connect directly to the board, USB or using a 3DR. USP provides no power output.

    Motorola Droid Bionic: Same results as above. Am I just not doing something right? 

    I did make my own microusb to female USB 2.0 adapter, and that works. I have no idea how to setup the TCP link from a computer, it just doesn't seem to be clicking right in my head, and I can't get UDP to work. Is there a guide out there I can look at?

  • Sony Xperia Go St27i (Mobile Phone)

    Andriod 4.0.4

    Kernel 3.0.8+ Ver 6.1.1.B.1.54

    Andropilot 1.4.14

    Standard OTG-adapter

    RCTimer 433Mhz 3DR-Clone

    Just installed and plugged in the radio. Instant GCS on the phone.:)

    Wicked cool. Tnx to all devs.


  • Got it working on a very cheap tablet with the 3DR!


    Model number: softwinerEvb

    Android version: 4.0.4

    Kernel version: 3.0.8+ bli@android-server0 #2

    Build number: 713B.V2.00.TZX.R01.eng.1204

    Steps to make it work:

     - Install "USB Host Check" from Google Play.

     - Run the app and press Fix. All items should be with a green check.

     - Reboot tablet.

     - Connect 3DR and enjoy DroidPlanner!! Yahoo!!

    I live in Viña del Mar, Chile and bought the tablet here:


This reply was deleted.