Hello! I am having a problem where my aircraft will reduce throttle to zero when I switch on Auto or Loiter Mode. 

Here are a few things to note: 

  • It works fine in Manual Mode
  • It works fine in Stabilize Mode
  • It works fine when I switch into Auto/Loiter on the ground (It will power up) 

I have an airspeed sensor, so did the following:

  • Verified cruise speed is set higher than airspeed sensor value when I kicked on Auto
  • Set cruise speed higher anyway
  • Tried disabling the airspeed sesnor

I was thinking it might be altitude related so tried the following

  • Increased loiter altitude to 1000M, tried to same with absolute altitude mode. It did seem to not want to descend as before and was nearing stall so I took over. But still no throttle.

Does anyone have any suggestions? I searched the forum and saw some similar issues but it did not appear any of the solutions worked. 

Any help is greatly appreciated!

EDIT: I think I found a relevant log file, and have attached it. 

2013-06-16 12-02 48.kmz

2013-06-16 12-02 48.log

2013-06-16 12-02 48.log.gpx

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Well, i figured it out. the throttle channel was revsered. lol... i had assumed this was not the issue since it powered up on the ground... but... alas it was. now i have an altitude problem, but thats a problem for another day!

  • Moderator
    In auto mode the throttle only works after take off speed is reached , loiter is also an auto mode. Throttle level is set in the parameters . Set the value for the cruise throttle, switch to auto and throw the plane
  • I had the same problem during my setup in my ground tests but in flight such thing did not happen. (I almost took a risk). at that time I thought it is matter of speed. now it seems it is not! now it is more risky. I had arduplane 2.72!

    I appreciate any kind of explanation!

This reply was deleted.