Arduplane 2.6 Auto mode throttle Zero Problem :(

Hi All ,

I had many crashes with my plane

I am using Arduplane 2.6 and pixhack (Not pixhawk ) and both has the same problem .

When I change mode from stab to Auto the throttle is off and plane start loss altitude while heading to waypoing  direction.

I do many searches for this problem but I did not get information that solve my problem ,

I use Airspeed. but I don't know if  it works well or not .

I thing the problem is simple to solve with parameter list but couldn't determine which one .

What's the pre requested step for the Auto mode ?

why the auto mode make the throttle works in ground ?

Dose the altitude for Home or waypoint Effect Auto mode ?

How to ensure that Airspeed works fine ?

Hope I can fine any helpful information from didrones members.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    Please post a dataflash log recorded when the issue is occurring.

    Thanks, Grant.

  • Try disabling the airspeed sensor and then set the cruise throttle to around %60

    • Ditto: "Try disabling the airspeed sensor and then set the cruise throttle to around %60" I had crashed 2 planes because the newest firmware had "enabled" the airspeed sensor with out me having a sensor.

    • I disable the air speed and set the cruise throttle to 60% .

      and test the auto mode in ground and it's not working . after that I set 4 waypoints  .

      then I moved with car to small  hill around the waypoints and change the flight mode to Auto and the throttle works fine , While i am driving the motor slow and increase and some time stops and start automatically

      note : the air speed is disconnected and disable from the parameters .

      any information describe this behaviors ? 

      Dose it mean that the Auto mode will work in the Air ?

      I don't want to loss my plane again :)


    • I'm not sure about the latest firmware but I do know that as a safety feature it will not throttle up if it doesn't think it's moving. It should be fine in the air. I had the same thing happen to me :] Took me awhile to figure it out. 

    • thanks Richard for Answer .

      Do you mean there is no need for the airspeed in auto mode ? if yes then what's the benefit of airspeed ?

      my cruise throttle now is 45%

    • I think if the air speed sensor is working it is more accurate however I like the cruise percentage because then you KNOW what it's going to do. But at any rate if you disable the AS sensor and simply use the cruise percentage and then it works.... that will tell you something wasn't right with the AS sensor so at least you'll have an idea what was wrong. So I'd try that first.

This reply was deleted.