Continue Mission on Signal Loss?

Hello DIYD experts! I've been trying to get the continue mission on signal loss to work for the last few days, and wanted to see if you can spot what I might be doing wrong. I've captured it all in the video above.

I'm running Mission Planner 1.2.60 and tried both Arduplane 2.73 and 2.74b.

Thanks guys!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Has this feature been fixed? This also happens for my  current set-up which is still Arduplane 2.73. On failsafe it does not continue on the mission but does circle and RTL even when set to continue mission. In addition, we need the old manual level back without the hassle of plugging the cable pls.. Thanks.

    • Hi ,,,,any updates on this situation,,,

  • Moderator

    A further issue: When the RC transmitter is turned off while testing Failsafe in AUTO (with short and long failsafe checked) the failsafe triggers RTL, but when turning the radio on again in less than 20 seconds the mode returns to AUTO setting up a potentially dangerous loop.

    What happens if in a situation where you may be flying in and out of range at the limit of your radio signal? Plane RTL's, then back to AUTO, then RTL, then back to AUTO, etc.

    It should only return to AUTO if the mode switch is toggled (which it does but only if 20 seconds is up (long FS))

  • Just to add my 2 pence worth when it comes to testing failsafes.

    Its one thing to turn off your Tx when on the ground testing but I would never to this with a model in the air. APM or not!

    The way I test Tx Failsafe is to set the end point of my throttle channel and the trim in such a way that I can go minimum throttle, then pull the trim all the way down, thus invoking the failsafe.

    Then to get out of the failsafe you just need to nudge the throttle up above the minimum and you have instant control, without having to wait for the tx to power up and re-establish a link.

  • 100KM

    I've run into the same problem with my X8.  I work around it by setting auto again through telemetry, after failsave has kicked in.


    1) Turn of transmitter -> plane goes into failsafe with circle, followed by RTL

    2) When the plane is in RTL (failsafe) use temetry to switch it back into auto

    3) The plane will now continue in auto while still in failsafe and complete it's mission.

    4) After the mission, turn tx back on and switch into another mode.  The apm will come out of failsafe and obey the transmitter again.

  • Thank you everyone for your participation in this. And a special thanks to Tridge, who is always going above and beyond our expectations.

    What a great community! Thanks!

    I'll get the Raptor up in the air tomorrow am with 2.74b and demo it's functionality...

  • 300km

    Hi Trent

    I've spent hours frustrated by the same problem. 

    I found it always defaulted to circle then RTL as if throttle, short, and long FS was enabled, but it did this even when they were all disabled.

    My solution (confirmed by others in this forum) was to program the receiver failsafe to switch to AUTO mode when the receiver signal fails (the same way you program it to set throttle to <950). It felt like a dodgy workaround but it worked (and I'm still using it).

    I've read that the most recent firmware handles that differently as some posters have suggested and I'll look into that when I have more time.

  • Trent,

    It looks like the APM is detecting the radio signal was lost. As I recall this is when the throttle's PPM signal drops below 950 or so. I don't have an APM on me right now to grab screen shots, but it should be under the failsafe tab in Mission Planner.

    Try removing the checkmark from the throttle failsafe actions. I actually disable this by default. I had an incident where I forgot to turn my transmitter on. After the GPS locked the system spun up and took off across the room. 

This reply was deleted.