Pixhawk Pitch and Roll Sensitivity in FBWA Mode

Me again with another query - hoping someone can help me out again!

I have my X-5 wing flying nicely baselined in manual mode but every time I try FBWA mode I have almost no response and have to revert to manual just to complete a turn at my local model club. Same thing goes for Autotune mode. I have double checked the LIM_ROL_CD, LIM_PITCH_MAX and LIM_PITCH_MIN parameters and they seem to be high enough (4500 and 2000/2500 respectively) so what could be wrong?

I also did a little ground check by holding over aileron all the way to one side, then slowly banking the aircraft over (in my hand). Sure enough, when it gets to around 20 degrees bank angle, the elevons are level with each other which would seem to indicate that LIM_ROL_CD is too low (certainly well below 45 degrees!).

I have done some searches on this issue and the reason for sluggishness for others was too low settings for these parameters, but I'm at a loss for my problems!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Moderator

    There are a couple of things that might lessen the effect of the problem, one is when you're doing your radio calibration to move your roll/pitch stick to the 4 corners and not just up and down/left and right. The other is to increase your Roll P value to quite a high value to give much more authority to roll (i.e. tune roll aggressively).

    • Hi Graham - thanks for your reply. Just to let you know that I *think* I have resolved this - by installing a pitot. So it may be possible that the airspeed approximation it was using before was somehow off and the Pixhawk thought the plane was in a stall and limited the max bank angle. Unfortunately my GPS packed up the other day so that plane is grounded for now but I managed 1 flight with the pitot and it was better.

      Once I can confirm for sure I will chime back in to close this out.



  • I'll check mine tomorrow. I actually never fly in FBWA. I fly in auto 90% of the time, the rest in manual or stabilized. (usually land in stabilized).

    • Jakob - you reminded me that I may still have an option for assisted - ie. Stabilize mode so I checked that and confirm that I can get unlimited bank angle. But as the wiki says it's not good for tuning the control loops (FBWA is preferred).

      Next I may try fit a pitot tube to see if that makes any difference. As I mentioned in an earlier post, disabling stall prevention makes the problem go away and I can bank the model to the full value specified by LIM_ROLL CD but I really don't want to fly with that disabled. So, in that sense it's almost as if the bank angle limitation is caused plan thinking the airspeed is too low. Before anyone asks, I do not have pitot enabled (AIRSPD_ENABLE=0)



    • Have you read the wiki on stall prevention? It sounds like you are working hard to troubleshoot a feature you don't undrstand. Stall prevention will lower the bank angle limits in FBW if your speed is too low. This prevents an accelerated stall. You have three options:
      1) Fly faster until your full roll limits can be reached.
      2) Lower your FBW_MIN
      3) Turn off stall prevention. We all lived without it for years, so it is certainly not an essential feature. If you get an airspeed sensor, you can try again.
    • Hi Iskess

      Yes - have read the stall prevention wiki and fully understand it.

      1. Flying faster does not help. No matter what speed I fly, the maximum allowable bank angle in FBWA is very flat and the minimum circle size I can fly is about 200m in diameter (barely within the bounds of my flying club). Same goes for pitch authority - almost nothing from full down to full up.

      2. ARSPD_FBW_MIN is 9m/s which is actually quite low for an X-5 wing.

      3. Hopefully the airspeed sensor will sort it out, but that will likely mean there is a major issue with the synthetic airspeed, which is disappointing.


    • 300km

      It can be frustrating can't it.

      My quick thoughts on your three points (from the point of view I expressed in my first post)

      1 and 2. The actual speed you fly won't matter if the airspeed parameters are wrong. If APM thinks you are flying at zero km/hr then it will enforce the anti stall limitations. 

      3. It's possible that you've happened across an issue with the APM code, but it would be a major one so I think it's unlikely to be the case if you're the only one with this problem.

      As I mentioned in my first post your experience reminds me of my Go Discover maiden.

      I'd recommend having a read through the airspeed parameters to see if everything is set up as it should be. 

      ARSPD_ENABLE and ARSPD_USE should both be zero.

      If that doesn't solve it then I agree with Iskess' third point. Turn off stall prevention and see if that helps.

    • The pixhawk will estimate the windspeed and thereby the airspeed, even without an airspeed sensor.

    • Just adding here the wiki that explain exactly your pb : http://plane.ardupilot.com/wiki/reversing-servos-and-setting-normal..."

      Using MIXING_GAIN to control mixing throws

      If you use the ELEVON_OUTPUT or VTAIL_OUTPUT options, you may find the MIXING_GAIN parameter useful to control the gain of the mixer.
      The default is a gain of 0.5, which ensures that over the full range of the mixer both inputs have authority (it can’t saturate). That also means that if you have one input of the mixer (eg. aileron on an elevon plane) at full range, and the other input neutral, then the output is only 1750. That may not be enough roll authority for some planes.
      If you change the MIXING_GAIN to 1.0 then you will get the full range of output from a single channel, although if you have full aileron deflection and full elevator at the same time you will saturate the mixer. It will clip output outside of the valid range of 900 to 2100 microseconds.

      So if you have found ELEVON_OUTPUT doesn’t have enough authority then try raising the MIXING_GAIN."

    • Hi Jean-Marie - thanks for your reply. I confirm that I have used Elevon_Output option for my X-5 and one of the first things I did was increase the MIXING_GAIN to 1 as there was not enough movement.

      Bear in mind that my problem only exists in FBWA/FBWB/Autotune modes. All the other modes I have tried (Stabilize, Auto, Manual) allow steep bank command when I move the stick. The steepest bank angle I can get in FBWA/FBWB/Autotune is around 15-20 degrees even though LIM_ROLL_CD is set to 45 degrees. Elevator authority has the same problem (much less than LIM_PITCH_MAX/MIN setttings).


This reply was deleted.