• Moderator

    Hey Nuno,

    Did you get this figured out yet? I had a somewhat similar experience when I received my board back from 3DR after having the fuse mod completed. It had been a while since I had to start from scratch and I learned a few things along the way.

    1) First load firmware.

    2) Making sure you have the board connected to your flight battery and USB, complete radio calibration.

    I forgot that I needed to have power from the batt in addition to USB in order to properly power my RC gear! Once I had power everything worked fine. Before that I couldn't complete the radio calibration either.

    Hope this helps,


    Nathaniel ~KD2DEY

  • Developer

    Can you connect to the APM from the terminal? Which com port is being assigned to the APM?

    You may have simply installed the wrong driver, this can a happen if you connect the APM before you have installed the Mission Planner software.

    To fix

    1. Plug in the APM and go to Device Manager in in Control Panel (short-cut is to press the windows key and type 'device manager')

    2. Expand the 'Ports (COM & LPT) section (or it maybe listed in the 'unknown' section

    3. Right click on the APM and select uninstall

    4. Unplug the APM and reboot

    5. Start Mission Planner, then plug in the APM

    6. If windows says Searching Windows Update for driver click 'skip' or 'close' (can't remember which it is)

    (other options to fix this are more brute force are two uninstall Mission Planner, reboot , the reinstall. But if windows has associated the APM with the wrong device driver, you still need to go to device manager to the 'unknown' section to remove the problem) 

  • Can anyone help
  • The connection os correct?


  • This maybe of little use, but have you triple checked your connections, and installed the latest Arduplane and Missionplanner software?

  • I had a similar error when the COM port was already in use. Not sure if this is the same

This reply was deleted.