Servo travel bigger than in Manual Mode! ArduPlane v3.1.1

Halo guys. Don't know where to post but here.

I have a problem with servo throw in elevon mode.

I followed this instruction to setup elevon mixing in transmitter first both manual and other mode.

So, I setup manually the servo throw using only receiver without the board. All went well working. Servo throw went to whatever they should be.

Then, I plug everything on my Flying Wing. Everything went well on Manual Mode. So i switched to FBWA mode to see the behavior of the elevon, the behavior seems good. They move to the desired position when I pitch or roll the plane. However (here is the problem), when I ROLL it to the Maximum roll. The servo goes to beyond the limit I set on the manual mode! You know, it will broke the hinges or any mechanism on it, right?

What I have tried: I went to Advance Parameter. Search for RC1_MIN (also max and also rc2) change it to the same as the min/max value on manual mode I've seen on "Status" on mission planer. (ch1out/ch2out). But nothing changed.

I also change value on the MIXING_GAIN. Not working also (as this trick work on ELEVON_OUTPUT)

Anyone can help me? Or any more advanced forum should i visit? thanks.
Sorry, English is not my first language.

Controller: Pixhawk/Fixhawk
Firmware: ArduPlane v3.1.1
Airframe: Flying Wing (new style elevon mix on Transmitter)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Moderator

    If you do your radio calibration correctly the movement of the servo's in Manual and FBW_A should be equal BUT note that when using elevons, full up and right will cause your servo to move way more than just full right by itself and the auto pilot will use that value as full right.

  • I don't have an answer, but heave you tried finding a parameter file for your wing or using something similar to your platform.
  • I have a similar problems. No solution found.

This reply was deleted.