Discussion group for ArduPlane users

1473 Members
Join Us!

You need to be a member of diydrones to add comments!

Join diydrones

Comments

  • Turnigy sentry ESCs might be worth a look in, they have switching BECs built in, so can handle something like double the current on the 5v line whilst also being more efficient

  • Castle seems to be better, I do have castle Mamba xl for my "baja ardurover" I haven't tested it yet ....but my test bench gave decent results
  • I bought a Castle BEC a few months ago and I've been staring at it :) wondering: Is the BEC necessary because the ESC is designed poorly?  Why doesn't someone make an ESC that isolates the motor pulse circuit from the BEC?

  • @David i tend to use BEC's i do admit having doing some analysis and it doesnt look that great. I generally use hobbywing pentium or similiar once for ESC

  • I really am of a mixed on this.  On the one hand, the amount of current that the ESC must supply to run the servos, APM, Rx, and Xbee is trivial compared to the motor's draw.  (This points to quality, not quantity.)  But the fact that longer servo leads causes the APM to send erratic signals makes it seem like power threshholds might be involved.  I guess what I need to do is throw an oscillascope on the leads coming out of the good and bad ESC and find out what's happening. 

  • Warren... Yep, the Xbee is on there too.

  • David, that is interesting! I,ll have try the shortening of aileron cables. Do you have a xbee connected? Maybe the extra cables are acting as an antenna inducing a bit of voltage ripple on the apm.
  • Warren, I agree with you on the quality of the current being the big factor.  However, capacity comes to mind... when I removed the aileron servos (which together have leads about a meter long) and attached a single lightweight servo with no extensions, the problem vanished.  When I added two or three servo extensions to this "good" servo, the problem reappeared.  Somehow, the added resistance of the long servo leads puts an unworkable load on the APM.  (I fly RC pattern planes and I have noticed that larger ESCs increase servo performance and resolution.)

  • Hi David, I think your right about a funky ESC being the cause of your issue, but I believe that it's due to the quality of the BEC's regulated 5 volts than the current rating of the ESC. My ESC was suppling a noisy 4.5 volts with similar results that you experienced. I.E. Pulsing servos and intermittent APM rebooting.
  • I realized something that I should have picked up sooner:  When you install an APM in a model plane that calls for, say, a 30 amp ESC, you may need to increase the size of the ESC.  I was recently getting some strange bugs (servos moving erratically in synch with the blinking GPS LED and the APM resetting spontaneously).  Clue: the problems decreased when I shortened the wing servo leads.  I slept on it and decided that the only thing the GPS, board logic, and all the servos had in common was power.  I put a 60 amp ESC in and, shazaam, no more problems.

This reply was deleted.
E-mail me when people leave their comments –

Cruise speed

Hi,I want to adjust cruise speed.At default settings I have a ground speed of about 42km/h (without airspeed sensor), and I think the optimal speed should be lower. In the mission planner I have value "Cruise speed", default 12m/s. I updated it to 9.5, but don't see any change in actual cruise speed.How to set cruise speed?Are these different settings with RTL speed? For RTL I prefer keep it as is - less efficient, but more reliable.Is it possible to adjust cruise speed during flight, providing…

Read more…
0 Replies

Long distance LiPo

I'm currently building a Talon (v3), mainly waiting for parts.While looking for high capacity batteries I found out two things; There are a lot of brands, and prices are still steep in the high-cap regions.I've also seen a few people on the Tube using 18650 cells, but none of those explain why.Does anyone here have experience with these custom 18650 packs?And which 'cheap' brands of standard 5~12A 4S seem to work best?I'm going to use an Emax GT3526 710KV swinging a 13x6.5 prop, which should…

Read more…
5 Replies

Quad plane pitch problem

Hi I have been setting up 2 quad planes, pretty standard setups...flying wing with 4 vtol motors and a rear mounted pusher motor. Both builds wich are on different firmware versions have reversed pitch in quad mode but correct pitch and pitch stabilisation in plane mode. I cannot for the life of me find a parameter related solely to quad pitch reversal. Is there anyone out there that can help with this? Thanks.

Read more…
2 Replies

PreArm Check Error : Gyros inconsistent

Hi guys, I have a Pixhawk from Radiolink and always in every first attempt of armed I get the error "PreArm: Gyro Inconsistent".The most strange thing is that i'm using only the external gyro+compass. i disabled the internal to avoid this issue. Also- I tried to recalibrate the gyros at least 5 times.- I changed the firmware version from the latest to the 3.8.53 because i have a friend with the same board and he does not have issues.But i have the same behaviorIf i disconnect the battery and…

Read more…
2 Replies