Issues connecting Pixhawk to Mission Planner

So, I finished buiding the Y6 today.  Tried to do the setup, but for some reason, only APM will recognize the Pixhawk, but Mission PLanner will not.  Normally it would not be an issue, since I could just use APM, but mission planner is the one that has the wizzard, and APM does not have the firmware for the Y6B setup that I need.  Any ideas on how to work this so that I can move on to calibrate my Y6?

Also, since I am asking for help, do any of you know how I can connect the FPV gear (3DR) to the main battery?  I would hate to have to use 2 batteries!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Guys, thanks for all the help.  

    I unplugged everything from the PX4 minus the button and the speaker (figured those would not interfere anyway).  MP still would not read, but I went to APM, and it was ablo to load up the firmware.  I reconnected everything and checked again, and APM recognized the system, so we are good to go!

    I did not do the mandatory calibration because it turns out, my PCCM receive did not survive the last crash!  I have a couple of OrangeRx receivers, but they are not CPPM, so I will just wait for the FrSky receiver to come in.  But I am glad to report everything is up and running now!

    PS: now both MP and APM will recognize the PX4 and connect without issues

    • That is good news Felipe. Let us know how it flies when you get it all working.

    • Will do. Just waiting for the new rx to arrive.  I will probably hit the local hobby shop today also looking for a rx; if I find one, I will probably buy it (no harm in having an additional receiver!).

    • 3D Robotics

      It's normal to always have to load the firmware first. Was this not clear in the instructions?

    • It IS clear that you need to load the firmware, but what is NOT clear is that you do not need to connect to do so.  This was the hiccup I was running into.  I am also not sure if MP would have been able to load the firmware without first disconnecting everything from the Pixhawk, as it was not recognizing the com port.

    • Felipe, in the event you choose to upload a different firmware in the future, it is not necessary to unplug everything.

      If I'm remembering correctly, I don't recall any documentation explicitly stating that it is necessary to upload firmware before attempting to connect. Since that, simple but vital, part of the workflow was not included in the instructions I incorrectly assumed that you had to "Connect" before you could start uploading.

      If there was a way to force MP to "Disconnect" from Pixhawk when "Install Firmware" is selected it would prevent any confusion. That, or add one more sentence to the documentation.

    • Completely agree with you...

    • Chris,

        I think it is clear, but it isn't clear if Filipe thought it was clear :) 

  • It's a long shot but when my Pixhawk arrived with the DIY kit the Arducopter firmware was not loaded. MP would always time out when I tried to connect. After I uploaded the firmware it finally got through. I assumed that the Pixhawk had to be "connected" to upload firmware.

    Everything has to be plugged in, and the correct com port selected, but go straight to Install Firmware in Initial Setup, do not hit "Connect," do not collect $200.

    Hope you figure it out.

    • Right. By the looks of Device Manager in his pc and MP, the drivers are installed. I just assumed he had already installed the firmware because he said he followed the Wiki instructions, albeit powered Pixhawk via the battery and USB at first. 

This reply was deleted.