Sudden loss of power

My wife wanted to take a look at the ceiling of my house, and I figured this would be a good job for the Y6, especially considering that I had just finished installing the STorM32 controller on my DYS gimbal.  So, I took off, changed into LOITER mode, and started looking at the roof.  About 3 minutes into the flight (video does not show that I took off and landed before), the Y6 started loosing altitude and hit my ceiling, and then fell to the ground (I reacted and went to full throttle, but no change).  

Damage was minimal (2 motors out of commission, some props and a motor mount and GPS mast), but I do want to understand why this happened.  According to TOWER, battery was at 75% at the time (I had my wife holding the tablet and checking battery life).  And I know I get about 8 minutes of flight from the Y6 (more when flying slowly as I was).  Checking the logs, it seems battery is to blame, but I am not so sure...

One thing that I did notice is that video signal was having issues (I could not see in the monitor any video, even though distance was small).  After the crash, video cleared up for some reason!

Anyway, any help is greatly appreciated in finding out the cause of the crash (I was lucky this was over my own house; would hate for something like this to happen over water or woods, or something like that...), so I am attaching the LOGS below to help others investigate.

Here's the video of the flight...


2015-08-02 15-53-49.kmz

2015-08-02 15-53-49.log

2015-08-02 15-53-49.log.gpx

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi guys! have the same problems with my Y6b on Navio2 and RPi3, ArduCopter 3.4 dev (aug 2016). Any solution has been found?

  • Checked the battery in the charger; 3.1V per cell (one was actually 3.01), so low battery is defenetly the cause.  Now the question is WHY did the battery last so little... And why was the voltage shown in TOWER higher!  Here is the Volt chart from MP:


    • Moderator

      Hi Felipe,

      The battery was not fully charged when you took off. Based on the starting voltage of 14.74v I would say it was about 80% discharged. A fully charged 4S Lipo would have a charge of 4.2v/cell or 16.8v/pack. Mission Planner doesn't know the charge state of your battery, it assumes you are always starting a flight with a fully charged battery; I assume Tower works the same way.

      AC3.3 RC8 in the Beta firmware makes an attempt to determine the state of the battery and warn you if the voltage is too low indicating you might not have a fully charged battery.

      Did you originally start flying the Y6 using 3S power? If so when you upgraded to 4S power you didn't update your FS_BATT_VOLTAGE parameter, it still has the FS voltage set to 10.5; it should be something like 13.5 for 4S. You also have FS_BATT_ENABLE set to "1" but you haven't defined FS_BATT_MAH. This combined with the low FS_BATT_VOLTAGE parameter effectively disables to failsafes for battery protection. I would suggest setting FS_BATT_MAH to something like 1320 as a minimum.

      It's also possible that you've been running your battery too low and have caused damage from over discharge. I don't think so based on the flight times your reporting, but it's possible.

      I get around 7 minutes on 4S 6000mAh so 8 minutes on 4S 6600 makes sense.

      I'd charge the battery and check the voltage with a battery checker the shows the individual cell voltages before your next flight.


      Nathaniel ~KD2DEY

    • You know, now that I think bout it, I placed it on the charger and let it charge until the charger announced it was done, but I did not check the voltage.  And I know that the charger has a max charge rate of 6A, combined with a maximum charge time of 1H, so it MAY be that the charger charged for one hour, but the battery was not yet fully charged (I did fly the day before, and I THINK I let it at 30% charge, but I do not remember; I am also not sure if I used this battery or the other one!).  Tonight I will charge it and check the voltage for the cells, and report back.

      I will take a look at the FS settings as well...  That's a good point you make!  THANKS FOR YOUR HELP!

    • Moderator

      Hey Felipe,

      What did you find out?


      Nathaniel ~KD2DEY

    • I have not had much time to test (been on business trips), but I suspect the issue I mentioned.  I will first start by rebuilding the Y6, and checking the voltage with the charger (completely charge the battery) to see what the voltage are per cell...

    • Well, finally got through fixing all the bugs.  Yeah, I know, it's been a loooooong time.  But I was just settling in to my new life (I moved from Panama to Costa RIca, moved to a rental house, bought a new house, moved again, and all this while getting used to my new job!).  

      Anyway, the Y6 is now put back together, and programmed.  I have yet to fly it again, but I already set up the FS as per Nathaniel Caner's suggestions (well, almost: I set FS_BATT_VOLTAGE to 10.75 and FS_BATT_MAH to 1,500 mAh, as I am using RTL instead of LAND).

      I also will use a switch to block the charging of the GoPro.  Not sure what I was thinking, but going over everything, I noticed that when I connected the GoPro Hero 3 connector, I allowed the camera to charge from the battery pack.  I know I at one point thought about loosing the battery of the GoPro to save weight and use the on-board power, but this messed with the balance of the gimbal, so I left the battery in.  I can disconnect the wire (it has the right leads to do so), but I think a micro switch will be easier to deal with.  But I am sure this was an issue with battery life as well!

      The only thing I have yet to get to work the way I want it to is that I had to setup my CH7 through the gimbal setup; I tried using RC pass through function, but could not get it to work.  Not sure if this will be an issue if I set the camera to auto follow, but it could be.  But since CH7 only handles the lights and the video input to transmit, it is not a real issue.  I also eventually want to switch from RC input for the gimbal pitch to MAV Link (I have a STorM32 with 3 axis).

      I will try to do a test flight this weekend, and will report back how everything is working.  

    • OK, did a test flight today.  Still not sure what is wrong, but the Y6 is flying very erratic.  If I even touch yaw, it starts oscilating, and since it keeps trying to turn left, you kind of HAVE to use yaw.  Trying to fly in stabilize mode is VERY difficult, so I had to fly it in loiter, and even so, it was not so stable.

      I went through 2 bottom props (its lifting the tail prematurely for some reason), and I ended up landing upside down twice (from very low height, and I always hit the legs first at a fairly slow speed, so no real damage done).

      I upgraded to the new AC3.3 firmware, and I know I have to auto tune, but to be honest, I am scared to fly it like this.  What should I start looking at?

      I am attaching the logs so that you can look at the data from the test flights...

    • Here's two of the 3...

      2016-03-06 15-14-03.log

      2016-03-06 15-34-59.log

    • It's not letting me post the last one...

This reply was deleted.