Hi all,

I noticed an issue when using auto tune in 3.2 / 3.2.1. Basically on the two occasions I enabled channel 8 to switch into auto tune I had real problems getting off the ground without tipping / yawing.

The first time it happened I had just upgraded from 3.1.5 where I had no problems with the overall behavior of the Y6 so I decided to reload 3.2 on the assumption I had simply missed something. After reloading all was fine and I flew a few times without issue so I then decided to try the auto tune. Once again as soon as I enabled the switch I have problems getting off the ground and tipped it this time. The funny thing is though once I did get it into the air it flew ok, although in stability mode it was drifting slightly to the left, and I managed to run the auto tune.

Anyway looking at a few things I wondered if I had simply enabled auto tune in the wrong place and by doing so changed some base parameters. I went into the Standard Params menu and set channel 7 to RTL and 8 to Auto tune and then wrote the settings but reviewing some of the videos they look to be setting these under Extended Tuning.

Now this may be a mission planner bug (version 1.3.20) but after setting channel 7 and 8 under Standard Params they don't show as being set under Extended Tuning, but they do show correctly in Standard Params. Also if I try to set them in Extended Tuning and hit write params and then select refresh screen they've gone again.

I haven't had a chance to test after running the auto tune so hopefully it has fixed things but wondered if anyone had any thoughts as to either the mission planner bug or the tipping.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Found the issue! Just as an update, and to close this thread off for anyone reading it in the future, it turned out that both motors on the rear arm of my Y6 had gone bad. Basically they would spin up looking normal but would then stop creating further power after about 35% throtle with the only teltale sign of pitching back and producing a sort of pulsing sound, as though there was a timing issue. The way I finally figured it out was running the motors up individually with props on to create a load and seeing how they reacted to throttle inputs.

    Anyway this started off being somewhat intermitent and potentially only one of them had been bad, hence it it didn't always appear to happen but eventually it became permanent resulting in not being able to get off the ground. Got to say though, other than tipping, it never resulted in a crash showing how resiliant the Y6 option can bee to motor failures that surely would have put other quads ot the deck.

    Hope this helps

    • Interesting....  On my last flight, I also had that pulsating sound, and I could se the GPS mast shaking.  I thought it was an out of balance prop, but now you got me thinking.  Anyway, I kind of splatted my Y6 into the ground, so any testing will have to wait until I get the new legs in, but I do have 2 spare motors in case one of them is bad.

  • Ok, as an update I took the Y6 out this morning and she went up without issue although there were a couple of differences.

    • the auto tune I'd done yesterday clearly had taken and had gone OTT on the reaction rate as she was reacting very rapidly to any banking with rapid adjustment as opposed to her usually smoother operation.
    • I took of from out decking which is pretty much flat.

    I make the last point because normally I take off from the lawn which is on a slight slope, maybe 7 degrees or so although I do try to pick the flatter spots, and this is where I had the trouble last time although as said I have taken off there without issue for a long time, especially on 3.15. Anyway feel free to give advice like power up on the level then move or continue as I always have powering up on the grass and not worrying about the slope.

    Anyway I plan on rerunning the autotune so will have to re enable the switch so I will report back if that has any issues this time round.

    By the way, did anyone come across the issue of channel settings not taking when applied under Extended Tuning.

  • It sounds like you are trying to take off in auto tune...  you have to take off in stabilize, then go to alt hold, THEN go to auto tune...

    • As stated above, definitely took off in stabilized, then alt hold and finally autotune. I have done autotune in 3.15 so am familiar with the process and when it starts etc.

      In fact the first time I did it before re installing after having a lot of fun getting it into the air when it did get there it wouldn't switch into autotune anyway so I definitely feel it's something changing in my setup when I commit the change under Standard params.

      My background is in helis so I'm used to avoiding tips on takeoff and would think my technique should be fine, and indeed hadn't given me problems on 3.15.

    • Hmmm...   So then you are having problems when you take off with autotune programmed to Ch 8 but the switch in the off position?   That should not have any effect on the drone...

    • Hi Felipe, I don't think it actually has anything to do with Ch 8 being set to autotune. I think it's potentially parameters being changed as I write the new settings for Ch7 and Ch8 under Standard Params in mission planner. As said there is clearly something not quite right in the way that Extended tuning doesn't reflect the settings from Standard params so somehow having the parameters change during loading or saving whilst changing the channel allocation doesn't seems possible.

  • Hi James
    Do you take off and then go into autotune mode by using the channel 8 switch or enable autotune prior to taking off?
    • Yes, I take off then go into autotune mode. This was confirmed 100% when I did it yesterday as once she was in the air everything was fine. and then when I flicked the switch autotune engaged and she started the tuning process.

This reply was deleted.