I am having trouble diagnosing my problem after updating firmware. For AC3.3, AC3.3.1, and AC3.3.2, when I attempt calibrate the accelerometer the GUI skips steps in the calibration procedure without my keyboard input. The following occurs

1) MP: Place level and press any key (Pause)

Me: Place vehicle level and press enter

2) MP: Place on left side and press any key (No Pause) > Place on Right side and press any key (Pause)

Me: Place vehicle on Right/Left side and press enter

3) MP: Place nose down and press any key (No Pause) > Place nose up and press any key (Pause)

Me: Place nose up/down and press enter

4)MP: Place on back and press enter (Pause)

Me: Place on back, press enter, fail calibration.

Now, I can calibrate the accelerometer without issue on AC 3.2, and think (correct if im wrong here) that I can run AC3.3.X without recalibrating from 3.2 > 3.3.2. I have read this is an odd issue that has appeared in the past, but after many different attempts to remedy the issue, I am thinking of either just running AC3.2 or trying calibration on 3.2 then updating to 3.3.2. Any input would be appreciated on how to ensure this does not cause complications in flight, or if this remedy will work.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had the same issue with the 3.3.x firmware, 'updated' to the 3.4-beta and I don't have the issue any more.

    I tried Mission Planner (latest) and apm_planner 2.0.18 - 2.0.21 all had the same issues.

    I tried apm_planner 2.0.21 with the 3.4-beta firmware and no issues.

  • I too am having this issue. I'm using a Pixhawk in a Y6 frame. Latest Mission Planner. AC 3.3.3  I've attached my tlog. 

    2016-06-20 20-57-40.tlog

  • I am having this same issue with ArduCopter 3.3.x.  I have tried multiple Pixhawks, both RFD900 and hardwired serial connections, and both MP and APM.  It happens every time in any configuration.  The happened after moving to ArduCopter 3.3.x.  It certainly appears to be a regression of some sort?

    • Attached is a short .tlog taken during the accelerometer calibration.  The GCS was APM Planner (Mac) and a serial connection tot he Pixhawk.

      2016-01-09 17-23-33.tlog

  • Developer

    This sounds like an issue in the mission planner itself.  You're using the latest official version?

    • Yes I am using the latest version, I suspected it is more likely the board after I tried this on both Mission Planner on my windows and APM Planner on my mac (dual boot laptop) with the same results. I am not familiar enough with the system to really say what is the real issue, but I'll try uninstalling then reinstalling Mission Planner if you think it is more likely the source.

      A similar issue was brought up on the Pixhawk RCGroups thread, and the user had success by forcing the bootloader. That didn't work for me, but I have been fine so far on calibrating on 3.2, then updating to 3.3.2. 

      (see post 6591, 6595, and 6597) > http://www.rcgroups.com/forums/showthread.php?t=1987175&page=440

    • Developer

      Michael Oborne says he can look into the issue if you've got a tlog from the attempted calibration.

      Maybe you could just performing the calibration again to create a tlog without too much info in it besides the calibration?

    • That was me on RCG and its back again now tonight Iv posted again, I also can't update FW I have posted in the 3.3 forum looking for help

      At a loss at the moment to what it can be
    • Right iv spent 10 hours on this and got progress, its related to telemetry for me, 

      Do you telemetary connected at all? 

      Disconnected everything from the controller, download the FW again and calibrate with nothing connected 

This reply was deleted.