APM 2.5 Quad on firmware 2.9.1.b throttles down and lands by itself even while applying more throttle in stab mod? It throttles back and lands as if the apm is telling it to like in rtl mode but from what ever altitude you currently are at and location, you are left with no throttle control but I was able to move side ways and forward and back to avoid obstical once I realized it was coming down.

Once it was on the ground the motors would drop to a low idle by themselves till I lowed my throttle to minimum, then the motors would shut off. Once in a landed motors off state you could not take off again till you powered down and back up again (by disconnecting the battery). I repeated this 3 times and got the same results, took off fine then after a short time it would start the slow decent and no amount of raising the throttle would avoid the settling. 

I had this happen with 2 different battery's, with final resting voltages being around 11.4v.

I have the battery failsafe set to rtl at 10.5 for if all else fails, so I don't think its this.

Any ideas people? Am I missing something simple?

Do you need more info? I tried replaying the log but I can find any for today's flights?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi guys just wondering if a solution was found for this problem? I had been flying my quad in stabilize mode with no gps or power monitoring for a while without any problems them something changed and it started doing the auto land thing.

    Thinking it might be related to not having a gps (fix) today I connected the gps and sure enough after a short flight it went up to 10 or 15m and then it came down very unstable but didn't do any damage other than a broken prop.  While it was going up I had no control over it and on the way down I'm not sure if I was making things worse or it was just very unstable on its own.

    I think the problem started when I setup the power monitoring in MP settings but not really sure as I added it but didn't fly it till some days later.

    One other thing to note is that when the above problems happened the quad was never more than 8m from the tx so cant be a loss of signal situation.

  • MR60

    Another quick way is to check, is to set your RTL altitude to 30 meters.  Then if it is a RTL, it will rise first.

    But, this is sounding more like a loss of radio, so it's landing, which since I assume this is happening close, something is most likely not right with your wire treatment and interfering with your signal (or your radio battery is low).  Check your advanced parms and see what you've instructed the copter to do when you lose radio contact.  If it says land (versus say RTL), then take a photo of your electronics, the antennas, the wires going between the APM and ESCs, APM and radio, ESCs and motors.

  • Yes I realise that voltage under load is lower, but I don't have logs to show voltage at the time off the issue. I wanted to be able to give you all a indication of voltage and a stable resting voltage was all I had.
    I don't believe my esc's have a voltage fail safe , as they are HK blue series flashed with Simon K firmwnot, which I was lead to believe does not have failsafe as part of being multirotor firmware.
    Also are you all saying this is normal behaviour for apm battery fail safe?
    I was under the belief that with the rtl box checked in mission planner, it should try and make its was home if it senses a low voltage situation. I have a apm 3dr power module for voltage sensing and it is set as such in mission planner.

    With this information do you still think it is a apm battery fail safe forcing it to land?
    I was at a slow forward hover at the times this occurred so I don't think it would have the load to draw it below 10.5 volts if the resting voltage once I landed was 11.4 -11.5?
    And I think it should of tried to rtl if my low volt failsafe kicked it.

  • MR60

    I had this kind of behaviour a couple of times, until I realized that I had a servo connected on the side PINs (the AN ones) which was sucking too much power out of APM, causing a kind of RTL.

    This behaviour disappeared after I powered my servo through the output PINs (not drawing power from APM itself)

    I think your situation is somehow putting your APM in too low voltage (even momentarily)

  • Might also want to check status of battery itself. I've had that happen and found that the battery had a bad cell. So now I charge in the balance mode or check the battery with a cell checker to be sure.

  • Developer

    I agree with Forest Franz especially about how the voltage under load can be lower than the voltage without load.

    The copter is undoubtedly switching into LAND mode because of a battery failsafe.  All the behaviour you describe is just how it should behave in that situation.

  • MR60

    The voltage under load is less than voltage w/o load.

    Try dropping all voltage faults to 9.7 and see what happens.  Also, many ESCs have a setting for low voltage response, which can include cutting power.  Check that too.  My ESCs (Turnigy) are set to 9.7 (low).  But with those faults being low, you need as a pilot to keep close tabs on flying time.  As voltage gets near low, the copter may behave irradically and crash.

  • Its a bit of a drama if you fly over scrub when it decides to land... Next time I get to fly I might try flicking to a different flight mode when it trys to land, to see if I can abort landing?
  • I think you are on to something with the low voltage side of things, as I normally don't draw my battveries down this far and this is the first occurance of this 'autoland' that I have had. Seems funny that the time I run my batteries a bit harder I get this 'autoland' fault, I think its linked. I wish I had my log so I could see if I to had a land command pop up.
  • I have exactly this problem too. None of my failsafes or flightmodes are set to land, but you can clearly see a land command has been made.

    It seems to be random, but last couple of times it occurred very shortly after I got "low volts" bleep from the spektrum telemetry.
This reply was deleted.