APM cannot start

Hi All:

   I had a strange problem. Today I connected the APM to RC, PDB, sonar, xbee as usual ( I am sure in the correct way). I found when I pluged in the battery those blue and red leds were only on for a short time and off after that the apm became dead. No leds were on. I tried to connected it via USB to a labtop, still the same.

   I wonder what happened, I just added sonar and lipo monitor and everything remain as they were. On wednesday everything worked well but today suddenly apm died. 

   Did anyone had similar problem or can anyone help?

   Probably the only solution is to buy a new apm. But the apm should not be so fragile. I freak out at what happened today.




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • A lot of the problems that you, and a few others report, are the symptoms of faulty wiring and/or batteries.

    I have now built 3 APM's for myself, and about 5 others for a LHS, and only one of those had a factory fault. (badly soldered accelerometer)

    Anyway, first test with only the usb connect, reload the code, and check that at least the board is working that way.

    I use Mission Planner, the artificial horizon should work without any further setup.

    (no rx, no sonar, no xbee, no gps connected)

    Then connect the gps and again check again that the board works, except it should also now show it's position.

    If you have the magnetometer installed, configure it's declination, and once again it should show the correct position in Planner, and now also point in the correct direction.

    All this without anything else connected!

    Now add the other stuff one by one, each time checking that whatever you add, does in fact worked correctly.

    I normally check the sonar in CLI mode, using Hyper Terminal :-)

  • I had a experience where a great grounding system shorted a loop from my soldering iron to the house, to the computer then usb while it had the battery connected. The APM and the usb connector was replaced. The oil pan survived with the short. If there is any powering to the controller consider that a alternate loop conduct can happen. The + connect to the iron zapped it instantly while powered.

  • Why don't you just unplug the sonar and lipo.  Maybe you mis-wired it and caused a short.

This reply was deleted.