Hi guys,

I'm just starting with APM and this probably could well be my first post here. So, a heartily welcome :)

On to the issue....

Prior to the APM setup the copter was running a naza lite with no issues at all; eventually I got bored of it and decided to try something more exciting...

So I changed to the hkpilot mega 2.7 with telemetry radios, power module, gps and so forth.

Some additional info and current setup below: 

reptile 500 frame

sunnysky 2216 900kv

dji 10x3.8 props and graupners 10x5 eprops

4s 4500mah

dji 30amp opto ESCs

minimOSD extra

ER9X on Turnigy 9X with DJT module and flashed D8Rii+ to D8RXP firmware 27ms with CPPM

1.2 fpv setup (not running currently unit I get the frame sorted)

Some background; I read a lot, troubleshooted  several issues successfully and everything else well.

Went through the wizards, everything is calibrated, PIDs OK, throttle mid OK, barometer shielded, compass OK, GPS OK, no vibrations, latest firmware etc...

NOTE: my APM is mounted a bit forward and yawed 45 degrees (arrow right), params set for that.

THE PROBLEM I'm currently going through is that when Im flying the quad in stabilize mode (worried to change to anything else, other than POSHold for testing) and I give input in due time (like 40sec within the flight) the RC controls seem to mix up. For example in the first phase of the test hover/flight with roll/pitch inputs, the inputs fly the quad normally... In the second phase (after the 40sec), it seems that the roll input (right for example) mixes up with pitch...To visualize it better, imagine you ONLY roll right and the quad pitches and rolls diagonally backwards...Same thing happens with pitch forward only, roll left and so forth.....

In the beginning I thought this was a compass issue (not valid in stab mode) or an accelerometer issue...calibrated again and again...I've researched some other scenarios to no avail....

I'm currently swamped with this and I'm constantly hitting a wall ....

Any good ideas as to what might be the problem?

HELP people !!!!!!!

EDIT: I posted this below as well (wrongfully maybe, im not sure)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey guys,

    A little update on this thread.

    It seems that I resolved the problem with all the quad funny angles,,,taking Spencer's suggestion below and Ricardo's from another thread, I tested the quad and paid careful attention to what it was doing, especially when yaw input was given to change orientation. All signs were showing simple mode...

    I checked and rechecked everything with Mission Planner and simple mode was disabled in all basic setting menus, as I stated in another response too. I had an epiphany to look for it in the full parameter list....and guess what.... there it was....enabled as enabled it can be :) I switched it off and days couldn't be happier..hahaha

    It's been some days that I found the fix and although Im not sure what was causing all the comm problems within the software menus, I can move forward now and tune the rest of the quad....

    Cheers to everybody for the suggestions!


  • Hey Mike,

    I tried to keep in the air to try to figure out what's going on. .also tried auto tune but nothing there...
    it seems the problem occurs after yaw input and/or some degrees of yaw rotation. Funny thing is that if I put it on the ground and without disarming the problem dissappears shortly and then comes back again....

    Demons and trolls?
  • OK, here is the log...

    I also calibrated the ESCs again..no improvement.

    I think next time I'm just gonna let the thing fly to the wall...

    2015-05-29 19-39-31.log

    • Interesting....

      You changed flight modes at least 18 times between Stab, alt hold, pos hold.

      Also, I checked your vibrations and there is nothing there.  Like no data at all which I've never seen before.

      I am far from an expert on this and it's been a while since I looked at an APM board so take all of this with a grain of salt.


  • Hmm... What do you logs say?

    Can you pull a dataflash log and post it up?

    Also, what are you seeing on your groundstation?  Any errors?


  • My guess is that you are in Simple Mode
    • Hi Spencer,
      No, simple and super simple are disabled.
      The quad will take input but at that point I have to figure out which way to move to stick to bring it back. .. it even seems that the inputs are rotating as time passes...I.e. while im pitching only back, the quad will start rolling/pitching diagonally back and then pitch turns to roll, like the board has changed orientation...
  • The motor order is different from NAZA to APM.  Any chance you've got the motor wires in the wrong locations?

    Or maybe you've got the wrong frame selected?  + instead of X?

    Or maybe you've got mixing on your channels of your Tx?



    • Hi Mike,

      Thanx for your response. 

      Unfortunately for me no, that is not the case. The motors are wired up correctly and the mixes are alright; just the ones required for the flight modes...

      Further the quad seems to fly ok in the beginning and then suddenly it gets a mind of its own re the inputs...every single time...


This reply was deleted.