Can't arm with radio

Hi there,

First of all sorry if this has been answered, I've checked posts regarding issues arming the copter but I cannot find a solution.

I'm having trouble to arm my copter and I'm out of ideas. I'm using APM planner which I've updated to the latest release and I've flashed the apm with the latest update. 

I don't get any prearm safety check error but I cannot arm my copter with the radio. I have done another radio calibration with no luck so far.

If the radio is switched off and I click on actions->arm in APM planner the copter arms with no errors (so the apm is ok). If I do the same thing but  switching on the radio the copter cant be armed unless I have the radio in the arm position (throttle stick down and rudder right). However if I try to arm just using the radio it doesn't work. 

Just in case I've done the radio and ESC calibration again. I wait till the gps is locked and I checked the rc input and everything seems fine.

Any ideas?


You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


    • I'm using the turnigy 9x, the throttle was reversed but I changed it, so that 0 is down and the higher values up. I'm going to double check all calibrations when I go back home. I'm using the telemetry radio but I don't get any message or prearm failure, I just read the initialize messages, and when I try to arm with the radio nothing happens. If I try to arm with groundstation (radio sticks in arm position + board powered with battery + telemetry) at least I see that it succeeded. 

      can't recall what the messages exactly are generated off the top of my head, but will do this again at home and paste the messages here. Thanks for answering. ;)

  • Normal Arming position on the TX is left stick to bottom right. 

    Try using bottom left. If this arm the craft then you need to reverse the channel

    Hope this helps 

    • Thanks for answering, I tried that too with no luck. :( At first I had the throttle reversed but I fixed that.

    • What is the flight mode set to when you try to arm it? it should be Stabilize to be safe.

    • Uhm... Just realized something, I'm not at home right now but when Im on the radio calibration, I see my throttle range is ok around 1100 < x < 1900, but using the terminal and testing the reading I Think channel 3 goes from 0 to 1000 something... while other channels readings match with the values in the radio calibration screen. Could this be the issue? Although then I dont get why is it arming from goundstation with the radio switched on only if the throttle is down... :S

    • Yes, its stabilize. ;) The weird thing is that if the radio is switched on I can only arm it if the rc is in the arm position and click on arm in the apm planner, but I cant just using radio. 

  • Hi,

    You have tried ARM using the groundstation? Is the same problem?

    • I can arm using the groundstation, as I said, if I have the radio switched off or if I have it switched on in arm position (throttle down, rudder right) but I can't arm just using the RC. :S which made me think I may have something wrong... but cant figure out what's the issue.

This reply was deleted.