Can't arm with radio

Hi there,

First of all sorry if this has been answered, I've checked posts regarding issues arming the copter but I cannot find a solution.

I'm having trouble to arm my copter and I'm out of ideas. I'm using APM planner which I've updated to the latest release and I've flashed the apm with the latest update. 

I don't get any prearm safety check error but I cannot arm my copter with the radio. I have done another radio calibration with no luck so far.

If the radio is switched off and I click on actions->arm in APM planner the copter arms with no errors (so the apm is ok). If I do the same thing but  switching on the radio the copter cant be armed unless I have the radio in the arm position (throttle stick down and rudder right). However if I try to arm just using the radio it doesn't work. 

Just in case I've done the radio and ESC calibration again. I wait till the gps is locked and I checked the rc input and everything seems fine.

Any ideas?


You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


  • I once had a similar problem, wouldn't arm and wouldn't show any error on the HUD. Recalibrated compass very carefully, and it worked after that.

    • Thanks for the idea! I will definitely try recalibrating the compass.

  • Hi 

    Can you confirm the following 

    1. Your radio (turnigy 9x) is Mode 2. The throttle and yaw stick is the left stick?

    2. Have you removed any trims from the throttle. Trims should be in the centre.

    3. Did you create a new model setup on the Turnigy 9X or did you use a previous one and adapted the radio settings for it. 

    Kind regards

    • Hi,

      1. Yes, it's mode 2. Throttle and yaw stick is the left stick.

      2. I haven't.

      3. I have created some modes in my radio following this guide,

      Thanks for answering. ;)


      Upgrading My Quadcopter from KK2.0 to APM 2.5 - Quadcopter Garage
      Like many drone enthusiasts, my first DIY quadcopter build used the KK2.x flight control board. I went through several iterations of my KK2 quadcopte…
    • Hi again,

      I've just gone through all the replies, checking my calibrations...and I read one of you first answers where you were suggesting to try throttle down-left. Turns out I just armed my copter holding throttle in the down-right position. \:D/ 

      Thanks for your help, really, much appreciated. Cant wait to do my first flight. ;)


  • There is a possibility here that's super easy to overlook. depending on your board of course.

    It could refuse to arm because of voltage alarm could be miscalculated. This is why you can arm when using Ground station through USB and not out in the field. 

    I had calibrated to feed my board 6v through my UBEC but one day i changed it to 5v and forgot to update the parameters. This meant that all of a sudden my board (without the power module) would read a drop in voltage and therefore refuse to arm.

    • Hi,

      Thanks for answering. ;) You are right that would be really easy to overlook but I dont think thats my issue. I've the apm 2.6 and I forgot to say that when I arm using the ground station I'm not powering by usb I'm using the telemetry radio. I've both setup a turnigy 9x and the 3DR radio. 

    • Do you have any trim at all on your radio? (just wondering)

    • Not yet. ;) I'm waiting to see if I can figure out this issue before doing my first flight and tunning anything. haha

  • What transmitter are you using. The futaba needs to have the throttle reversed. Check all of you calibrations. If you have the telemetry radio what messages are being generated.

This reply was deleted.