Cannot connect 3DR radios to Tower on Android

I don't know if it's a MP/AC version change or that I reinstalled the drivers (1.9) for the radios.

Are there certain settings the radio must have in order for Tower to work? It worked fine for months (Droidplanner 2 as well).

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Sorry delay answer I wasn't at home

    here my 2 cents

    3701998607?profile=originalI opened a Tower group so we can cocentrate all Tower information there If you want to participate is here: 

    • Thanks, I'll give those settings a try. I don't recall those 3 boxes being unchecked before, but with my memory who knows.

  • Would someone care to post a picture of their radio settings?  Lugging around a laptop is getting old.

  • I just update my radios and today I check with Tower and work's for me, Tablet Nexus 7 2013, APM 2.5 Can you share your RM config page if I, or others, notice something different?, What tablet/phote do you have?

    • Both radios have the settings as below. Mavlink works fine on the PC.


    • I don't have any box checked, air speed 32, min freq 89500, maxreq 93.500 ; try there

      What tablet do you have?

    • I think it was pretty close to what's there now, but will try anything to get it working again. The above screen capture is exactly what was loaded after clicking on 'Upload Firmware' button.

      I use my Droid Maxx HD phone and Droid Turbo, and also a Kindle Fire (converted to android). I mainly use Tower for audible information; rarely look at screen, but it is nice to have.

  • It was working perfect for months. Here's what's changed:

    1) Upgraded Pixhawk to AC 3.2.1 (was working with that IIIRC) and now 3.3 RC3

    2) Reinstalled firmware on radios.

    That's all I can think of. My gut feeling is it has something to do with the radio firmware settings, but darn if I can remember what the exact settings were before. I tried it on two different Android phones that worked before; neither will connect. 

  • have you tried changing the connection's baud rates?

    • yes, I did and also different android devices

This reply was deleted.