Compass Problems

Compass inconsistency. This is a  PixHawk Lite with an M8N GPS. The external compass is on top and pointed in the right direction.
Both compasses calibrate. They show up the the parameter list with Id's and offsets.
But, in the main window in MP only the internal compass moves with the quad. I turn the external compass and nothing happens. I have tried different firmware, 3.3rc12 and 3.2.1 and versions of MP. Does anyone have an idea what the problem might be or what I might try next?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've had also the same problem yesterday after upgrading the firmware.
    It was very anoying, and the more I tried to solve the problem, more errors came up, like the "Bad AHRS" on top of the "Error Compass Variation".
    The only solution was to reset the pixhawk by changing (from) plane to multicopter (anything different) and then back to plane.
    And the problem didn't ended right away. I also had to recalibrate compass and the accelerometers. The accelerometers failed to begin the calibration many times, until it finally started and got calibrated. After that all errors disappeared.
    This was my case. Changing firmware was the last resort after failing everything before.

    Good luck.

    • Thank You my friend,

      I will try to change it to plane and back and see.

    • That appears to have solved the problem. We shall see when I can get it to fly.

      Thanks again


    • You're welcome!

This reply was deleted.