Morning All,

I am trying to get and S800 Evo flying smoothly to waypoints on a pixhawk with Arducopter 3.1.2, however despite playing a lot with the PIDs I am still getting uncomfortable twitches when changing between loiter-based flight modes (e.g. Loiter->Auto-RTL and so on)

Looking at the logs I can see that not only is the S800 twitching when I switch from, say, Loiter into Auto mode,  but that also the DesPitch itself seems to be temporarily twitching, inverting after an overshoot. That I don't understand.

I can understand why actual Pitch might overshoot a computed  Desired Pitch when as it tries to home in on the new required lean angle to fly to a waypoint, but why is the DesPitch itself oscillating, and even inverting here?  Is this an IMU / Gyro / Vibrations issue? I have got vibrations down to well inside the +-3 recommended band, and the pixhawk is mounted on the damped IMU board under the S800.

Graph and log attached for any that might shed some light!

Many thanks

(in log see around 14775 for example, towards the start. test also repeated 7 or 8 other times in the flight)



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok, I've solved my problem!  In short by using the ANGLE_RATE_MAX parameter, and even at the default of 18000 it makes a huge difference, and at last makes the craft safe. I've now dropped it down further to 9000. 

    However for some odd reason it didn't appear in the build I had loaded which I had thought was 3.1.2.  I originally cloned arducopter master branch I think from Github, in early march (i,e. after 3.1.2 release), and the release notes there came all the way up to 3.1.2.  I modified the SBUS.c file to work on my futaba R7008 and then compiled.  However the ANGLE_RATE_MAX parameter wasn't in that build I cloned for some reason.

    When later digging around the code for arducopter 3.1.2 branch (not master branch) on Github, I found this promising ANGLE_RATE_MAX paarameter in there, and wondered why it wasn't in my build. Anyway, I never figured that out, but I rebuilt what I now believe is the proper 3.1.2 release (with my SBUS mod) and uploaded, set the ANGLE_RATE_MAX to 90000 and all is now well.

    Thank goodness for this new parameter, though, because without it i imagine large powerful MRs in general would be unsafe.

  • I've tried dialling my Loiter Rate P all the way down to 0.2 but it still makes big twitches going Loiter->Auto. It really shouldnt have to.

  • Well today I did some more testing and at one point when I switched from Loiter to Auto in Mission Planner, the whole rig  almost fell out of the sky.  It twitched, and then side slipped about five metres before finally recovering just in time. Thought it was a gonner.  Not cool.

    Would be interested to hear other people's experiences.  I have tried turning the Rate Loiter P down to about 0.3, bit it still twitches a lot on mode change.  I am also wondering if turning down the Rate PID would help, but when I do that it becomes too sluggish in stabilize mode.


    • We have seen the exact same problem. Never did fix it .....................seems to come and go ???

This reply was deleted.