Update 19/02/2013: problem has been resolved. See discussions below for conclusion.Hello,I am in a dead end that frustrates me to the point I might give up soon...any help welcome.I have not yet flown my new quad that I try to finalize for weeks now,learning step by step how to solve the hidden road blocks. Except this time I am at a road block I can't resolve and do not find any info on the wiki.This is the issue:-I am at the stage where I have apparently succesfully calibrated the ESCs until step 6 of the wiki automatic calibration procedure-After that if i turn on the quadcopter again and I arm it with the throttle stick bottom right for 4 seconds,then comes the issue:Any throttle stick position make the four motors turn at a constant speed (except full down where motors stop). It is as if the throttle stick would be an on/off switch.If i connect one esc directly to channel 3 of the receiver,then stick works as expected.So is it a defect on my APM board,not able to send variable pulses to the output rail? is it a problem with 2.9.1?(i was in stabilize mode)Any advice/ help please!Hugues

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Hugues,

    Could you solve your problem? I have the same problem I haven't found the solution!


    • MR60


      Yes this was solved long ago (1.5 years ago!). The issue was my P rate was on a value of 11 instead of 0.11 (100 times too much).

      I just reverted to the default PID values in mission planner and problem was solved.

    • Im having the same issues as in Hugues video posted earlier , Im  using the 1.

      3.17  mission and arducopter  3.2 . I cant seem to find where the PID settings are in Mision planner in this 1.3.17 although I see under config / tuning and full paremeter  list there at PID settings there but default  for throttle  all seem normal see attached file . Any ideas anyone , seems Hugues issues were solved by PID settings but Im not sure Im in the correct location to check mine

  • which exact value of P there is alot of P s ... cause I have the same problem 

  • Developer

    I've posted over on Jeremy's post as well but I suspect the issue is not with the APM but with the ESCs.  Some ESCs require a very low throttle position (pwm of below 1000) be sent to them before they will operate.

    The issue may be that your transmitter provides a pwm value higher than this by default.  Could you check what your minimum throttle pwm is by looking in the mission planner's radio calibration screen?

    What does not fit with this theory however is that you can make the motors turn by directly connecting to your receiver.  this is very strange because the APM should output the same min throttle as your transmitter as long as you've done the radio calibration recently.

    Could you also try disconnecting all ESCs from your APM except that one that you have confirmed works when you connected it directly to your transmitter's channel 3 output?

    A video of what you're seeing and a copy of your parameters file would also be extremely helpful.  You can save a copy of your parameters to a file from the mission planner's Configuration, Advanced Params, Adv Param List screen.


  • I don't know if this helps, but I'm having what could be a similar problem using APM 2.5 and 2.9.1 on my DJI450 quad.  I started describing it in the comments on this posting:

    The two differences are (1) I'm using ESCs that cannot be calibrated (the DJI Opto 30 model), and (2) instead of getting a fixed throttle response, I get no throttle response (which is like saying mine is fixed at 0).

    It'll be interesting to see if this is really just two versions of the same problem.  I'm currently at a loss for what else to try.

  • MR60

    So I have done the following :

    -I have calibrated the ESCs manually , one by one , succesfully: with direct connection between ESC and receiver, I get a normal throttle control (input=output PWM).

    - I have reconnected all 4 ESCs to the quadcopter, redone radio calibration. I can arm without problem and I am in stabilize mode.

    But still same problem. I illustrate with pictures:

    First picture: motors are armed, throttle stick full down : ch3 in->PWM =989, Ch3 out->PWM=989



    On the second picture I push the throttle stick at about 50% : ch3in->PWM=1633, ch3out->PWM=1119


    On the third picture : I push throttle stick at maximum : ch3in->PWM=2012; ch3out->PWM=1267


    In addition I notice that leaving the throttle at same position, the ch3out varies between 1200 and 1400 in a kind of random way (ch3in stays constant).


    Is this normal or do I have a problem with the arducopter code/APM ?

  • Hugues,

    I've been in RC since 1980, electrics since they first came out, and Arducopter since about three years back.

    And I say calibrate your ESC's one by one using the correct battery, and straight out of the throttle port on your RX.

    Once you KNOW the ESC's are working, you can start to fault find the rest of the system.

    And sometimes you have to do the APM upload/config/radio calibration a few times before it works properly.

    Yes, I do electronic repairs/fault finding for a local RC supplier/ Drone supplier :-)

This reply was deleted.