Trouble arming quadcopter.

Hello all,

Sorry if this is not the right place to post this, I'm new here...

Okay, so I have bought parts and built my quad for a school research project, I just can't seem to get it to arm now its built. It's all wired up, Ive calibrated the ESC's (they work when connected to the receiver) and loaded the firmware and done all (I think) the necessary calibration. 

My problem is it just wont arm, no matter what i do... The transmitter stick positions are all showing up right in mission planner (using a 3DR radio to connect) and the GPS has a fix and all accelerometers appear to be working (on the artificial horizon). 

There is a solid blue light (3D GPS fix IIRC) and a flashing red on (not armed?), but when moving the throttle stick bottom left or right (i've seen both in instructions) nothing happens. When running the motor test from the Mission Planner CLI all motors work. I've also tried disarming preflight checks and reinstalling the firmware (happy to do again).

Heres a rough breakdown of my equipment...

 - Turnigy 9x tx/rx

 - Turnigy plush ESCs

 - Ardupilot module with GPS

 - 3DR radio link to ground

So, if anyone here would be willing to help it would be greatly appreciated :)

I'm a newbie when it comes to Ardupilot, so it might be a simple fix (hopefully)!

Thanks heaps,

Lucas Fraser

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thanks for all the help everyone.

    Wiping the EEPROM and clearing the logs then reinstalling the firmware fixed it. Managed to get our first flight in today.


    • I'm setting up a Tri-copter for the first time.  Ho do you wipe the EEPROM and clear the logs??  I'm having th exact same problem, and have already done all the rest.



    • 3D Robotics

      @Tim: CLI Erase

    • Thanks, Chris!!

      I got it fired up now.  I had to do that, as well as the ESC calibration.  Now I have to wait for Missouri to thaw a bit, and get it out of my dining room to try it out!

  • Well,

    I've tried all your suggestions, reinstalled the firmware and re-calibrated all the gyros, manometers, and radio.

    Still no luck, all radio readings are showing up fine, and trying every stick position doesn't yield any results. There isn't anything showing up in mission planner to say that is failed a pre-flight check, Just saying DISAMED on the HUD.

    Any further help will be greatly appreciated.



  • Hi Lucas. Have you made all first time calibration ? (radio ? magnetometer ? Gyros ?) If you haven't, AC has a pre arm function wich won't let you arm if any of this haven't been calibrated. You can disable this pre arm check in Mission Planner (I sugest you don't do that). One way of verifying this is to connect your apm to Mission Planner, connect your battery, and try to arm it. If a pre arm condition fails, you wiil see the reason why on MP screen). Attention : DO THIS WITH YOUR PROPELLERS REMOVED to avoid any accident.

  • Developer

    Another possibility is that it's failing one of the pre-arm safety checks.

  • I have had similar problems and expect more as I learn. I have found that once I calibrate the TX in Mission Planner I then have to calibrate the ESC's. I do this one at a time. The most recent issue was the light in the board locked to ON but the motors would not start. If I were you I would replace the Turnigy Plush ESCs with the Afro one from the same supplier.

    I hope it helps but then it may not.

  • 3D Robotics

    Make sure you're in stabilize mode (it won't arm in auto modes) and your throttle channel isn't reversed. 

This reply was deleted.