new PIXHAWK APM will not do anything in Auto Mode

Hi All:

Decided to bite the bullet and upgrade to PIxhawk. Got everything and everything went smoothly.Used Futaba sbus link from RX to PixHawk. Works fine. CH1 CH2 for speed and steering CH7 - learn CH8 mode.

Configuration is Ardurover 2.46. MP 1.3.10. Compass and Radio calibration went well. Left all parameters at default at this time. Mavlink works fine over 3DR radio.

Installed on 6x6 with TrexJr motor driver. Manual mode works great. 6X6 steers well and speed control is nice and smooth.

Next, loaded an old waypoint file and wrote to Pixhawk. Read back from Pixhawk. All good.

Next took 6x6 outside and got GPS 3D lock in a few minutes. 11 sats hdop 2.05. Both pwr leds are green. ACT led is blinking blue. Big RGB led is solid green.


Drove a few inches in MANUAL. I guess it does not have to be armed to move in manual !


Pressed blinking safety switch and it went solid. MP DISARMED message went away. Good to go ?


Now switched to Auto mode. MP window shows Auto.BUT 6x6 does not move at all. Switch back to manual and it moves under RC control. Back to to auto - just dead in the water !


Totally perplexed. Any help or ideas appreciated. Either something is busted or I am doing something silly.






You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had a similar issue on my first time setup..  My problem was resolved by reversing the throttle channel. 

    I had the same symptoms, worked in manual, but no go in auto. It was steering, just no forward motion.

    I don't know if this will help you or not..  Good Luck

    • same happens to me. Runs fine in manual mode, does nothing in auto mode.

      Pixhawk with latest stable firmware (2.47)

      Spektrum dx6i

      RCMAP: thottle on channel 2 (left stick)

                     steer on channel 1 (right stick)

      7 satellites found

      3 WP written on pixhawk

      sometimes it goes in auto but does nothing , sometimes it replies "unsupported command 252"

      When I click on start mission it goes on "hold" mode...

      help! :)

    • Admin


      The ArduRover firmware expects to use the aileron (Roll) joystick for steering and the elevator (Pitch) joystick for the throttle which is the right joystick in Mode 2.

      This means that the throttle input to the firmware must have a neutral at 1500us because the firmware is expecting to go forward with a throttle input of greater than 1500us and backwards with a throttle input of less than 1500us.


      TCIII AVD 

    • Solved,

      I've reversed the steering and the throttle channel on the calibration tab of APM planner (I have read somewhere that this should have worked)

      thank you!

  • Admin


    Do you have a mission loaded?

    If you have a mission loaded, how far apart are the waypoints in meters?

    What is your waypoint_radius parameter set to?

    What is your cruise_throttle parameter set to?

    What is your cruise_speed parameter set to?

    Did you calibrate the ESC throttle input when in the Manual Mode?

    It is interesting that you have a throttle output when the Pixhawk is not ARMED. I have never see that before.



    • Not sure what the problem was. Reloaded 2.46 and all is now well so on to more testing...



    • Nah. part of of the problem was stupidity but I am still stuck..  The reason why it wouldl work in manual without being armed was that I had actually bypassed the APM outputs so the motor was getting signals direct from the RX. So manual was fine and auto did not work ! I rewired it per the wiki so sbus to pixhawk, out 3 to throttle servo and out 4 to steering servo. The throttle servo works fine but no signal on out4 at all. So all we can do is go back and forth in straight lines. Is there any way to resssign the outputs or see what is going on. The test servos are fine. They work directly with the RX and I can interchange and either one will work on OUT3 but none on OUT4.




      - vijay

    • Admin


      Have you tried either OUT 1 or OUT 2 to see if the steering PWM signal is on either of those two outputs?

      I recommend a servo/receiver tester like this to do troubleshooting: GWS MT-1 

      What do your RCMAP parameters look like? What input channel is on the THROTTLE, PITCH, ROLL, and YAW?



    • TCIII:

      You are right. The steering output is on OUT1. The wiki documentation is incorrect. I tested the thing with the sbus - ppm converter but I am going to see if I can remap the RCINPUTS.My mapping is the default. I have an arduino I built some time ago that gives me a readout on servo inputs but otherwise the tester you recommended would have been very useful.



      - Vijay

    • Admin


      Unfortunately the ArduRover Wiki has been the victim of commonality changes over time that cause inaccurate information to creep into the Wiki.

      For instance, I have used servo output 1 for steering and servo output 3 for throttle on my APM equipped rovers. However, I have used servo output 1 for steering and servo output 2 for throttle on my Pixhawk.

      A lot of the steering and throttle servo output confusion comes from whether you are using a Spektrum Remote Receiver as your R/C receiver or a standard R/C receiver using a PPM encoder or a Futaba S- Bus receiver.

      That is why there are the RCMAP parameters to remap the receiver inputs to whatever outputs you want.


      TCIII AVD 

This reply was deleted.