I've tried everything!!  It was jerking, so went to get the firmware and re-calibrate.  Took me hours to figure out the driver just wasn't compatible w/ Windows 8.  Everything is installed and supposedly calibrated, and it's STILL jerking and won't just point down smoothly like it did before this happened?  

Any other ideas?  I've scoured the web and did everything.  After 3 days of this, I'm still in the exact same spot.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • and just for fun, make sure the wiring isn't wrapped around the pole that holds the GoPro

    • I know what you're talking about with the wrapped wires, first rookie mistake on the first flight.  There's definitely a problem with the tilt.  I'll check out that video...

    • Woohoo!!  Like butter...I'm embarrassed to say how long I worked on this.  If it wasn't for the incompatible windows 8 driver, it would have taken me 15 minutes.  

      Thank you!!!  You saved "Hal" from being thrown out the window.  

  • Be careful when calibrating the gimbal.  I had to recalibrate mine a few times.  Make sure that the IMU is laying perfectly flat on a solid surface and be careful not to touch the gimbal while performing a calibration.  It finally worked for me once I followed those steps.

  • Check the set screws that secure to the motor shafts.

  • It's the controller (tx) recalibrate ch 6

    • How do I do that?  I'll look it up, but if you happen to have the short answer, let me know.  I'm convinced it's the controller since it's doing the exact same thing as it was before I started updating firmware, re-calibrating, etc.  It points straight just fine, just jerks on the "tilt" and won't point down all the way.  

  • If it is not a calibration issue then it might be a hardware problem like the position feedback

    or motor drive.

    I would ask if it is possible to remove the drone control loop by removing the props and holding the drone

    in your hand, moving the orientation and observing the gimbal response.

    This might isolate the system to drone or gimbal.

  • I had what sounds like a very similar problem. I calibrated the controller and poof, the problem was gone.
This reply was deleted.