Need help with Canon S-100 hookup

I got a Sparkfun 5V Breakout (NCP1402), some JR servo lead extensions from HobbyKing, and a right angle mini USB cable from Amazon and made the rig shown in the attached photo (USB cable not shown). I also installed CHDK and the 3DR script on the S100. I can apply 1.5 volts(C cell) to the input of the breakout and get a clean 5 volts out and it will trigger the camera just fine. BUT, I can't seem to get anything out of PIXHAWK! I have configured the Ch7 switch on the TX to "Trigger Camera" and have TRIED to configure PIXHAWK to output to either relay 1 (Aux. out 5) or servo 11 (Aux. out 3)[I THINK, since the gimbal tilt (servo 9) is attached to Aux. out 1] I find most of the documentation very confusing since it refers almost entirely to APM with little reference to PIXHAWK!!!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have same problem and short on time. Check my thread please.

  • After further testing I think I know why the Sparkfun breakout isn't working. I just need to borrow an oscilloscope to find out for sure, but it appears that the Sparkfun is slow to respond. If you apply a steady input it (eventually) gets to 5V out, but if it sees a short duration pulse as from Pixhawk it just never gets there.
    • While waiting for parts I decided to take a look at the schematic for the Sparkfun NCP1402, see attached. With a 10 uF capacitor on the input and 68 uF on the output its no great wonder that it can't operate on a short pulse. My bad that I didn't look at that first, and ARDUCOPTER BAD for recommending it: "To convert to 5V, you’ll need to integrate a step-up converter (like the one here from Sparkfun) in-line with the cable to trigger CHDK."


  • First, thank you all for your quick replies and links.

    OK, I think I have it sorted out. The Sparkfun step-up break out does not seem to work properly with Pixhawk. If I apply 1.5V (1 C cell) to the input I get 4.97V out, if 3.0V input(2 C cells) I get 4.98V. But if I connect to Pixhawk pin 54 (Relay 1) I get 3.3V in, but only 3.6V out. That is a very strange result since it does not appear to overload the relay out from Pixhawk, but it will not produce the 5V required. I guess I will fall back a step and build Marco Robustini's step up circuit which uses +5V from the servo rail (see Eric C's link above).

    While on the subject, I went to relay 1 out because when I tried to use RC-11 servo out I could see SW7 output, but it was only a little more than 0.3V out. I haven't taken the time to sort that out yet, suggestions would be appreciated.
  • You may find this link of use:

  • I'd post this same question in the Pixhawk group and the ArduCopter group.
  • I am interested in everything Mr. Morris is asking also...
  • PS: At this point I have only bench tested using the TX to operate the camera. I have not tried to use a DO command in a mission yet.
This reply was deleted.