Tarot Gimbal Windows 8.1 Issues

After closely watching some video I shot with my gimbal I noticed some slight vibrations. I wanted to check the setting for the gimbal but I'm having a heck of a time getting it to connect to my PC. I have a feeling it's due to me running Windows 8.1. I see the USB in devices and the com#. But the com number isn't selectable with in the Tarot software. I've tried the drivers suggested in an RC Groups thread still no luck. I have a feeling it's a windows issue as there is the little warning mark on the device, I've tried updating the drivers with the installer and via windows. I noticed there are baud rate settings for the device within windows, do any of these need to be changed???

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Tried latest FTDI drivers, no change. I found a thread on RCgroup and they suggested an older driver from Prolific, that also didn't work. Tried both USB 3 and USB 2 ports. I can see the device in device manager and it gets assigned a com port but there is a warning, yet when I dig into the device manager everything seems to be functioning correct. I might just have to find a Win 7 machine.

  • If you are using USB3, this might be an issue. I had to connect via a USB2 hub to get my com ports to behave. But I was using Windows 7 and not 8.

This reply was deleted.