I had an awful crash last week where the remote totally disconnected from the Iris, showing zero's on the screen.  All in all, I think I can fix the gimbal and the Iris.  I've been trying to re-bind, following the instructions and the video, and it's still showing zero's for battery.  After messing around with the controller telemetry connection, the android tablet telemetry is now completely disconnected.  

I can't seem to get either one connected?  It almost looks like the controller is, except for the zero battery column.  

Anyone know the answer to this one?  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • 3D Robotics

    Hi Heller,

    I saw your ticket in our queues.  Please send us your recent logs, the instructions can be found here:

    We'll take a look at your logs and let you know what's going on.  

    • Thanks, just getting around to this.

      Here is the log:

      Log File C:/Users/Helleren/AppData/Local/Temp/tmp93BE.tmp.log
      Size (kb) 6309.341796875
      No of lines 85284
      Duration 0:06:01
      Vehicletype ArduCopter
      Firmware Version V3.2.1
      Firmware Hash 36b405fb
      Hardware Type
      Free Mem 0
      Skipped Lines 0

      Test: Autotune = UNKNOWN - No ATUN log data
      Test: Balance/Twist = GOOD -
      Test: Brownout = FAIL - Truncated Log? Ends while armed at altitude 4.65m
      Test: Compass = WARN - Moderate change in mag_field (31.88%)

      Test: Dupe Log Data = GOOD -
      Test: Empty = GOOD -
      Test: Event/Failsafe = FAIL - ERRs found: CRASH GPS_GLITCH FLT_MODE FS_THR
      Test: GPS = FAIL - GPS glitch errors found (4)
      Min satellites: 0, Max HDop: 99.99
      Test: IMU Mismatch = GOOD - (Mismatch: 0.39, WARN: 0.75, FAIL: 1.50)
      Test: Parameters = GOOD -
      Test: PM = FAIL - 35 slow loop lines found, max 12.18% on line 1776
      Test: Pitch/Roll = FAIL - Roll (166.61, line 79180) > maximum lean angle (30.00)
      Test: Thrust = GOOD -
      Test: VCC = GOOD -

    • I did send the rest of the logs to 3DR and besides the brownout & compass error, it seems as if nothing else went wrong?  I gotta say, it didn't seem like it was doing anything I was trying to do w/ the controls while I was trying to land in loiter.  

      Been a busy week crashing & trying to fix drones.  This has been pretty humbling because it all happens in a split second.  It's not like flying a plane at all.  

      Tomorrow I'm bringing it to a co-worker to see what I'm doing wrong in the binding.  I've followed the instructions to the letter, it's not binding.  

    • Got it!!  It was a vibration issue too.  With the help of a calmer person, I was able to bind and re-set the parameters getting the battery  back on the controller screen.  Hoping liquid nails will work on the gimbal, still not sure about that one.  

      I ordered this little blade nano to annoy my family & practice manually around the house.  It was a little too windy that day for a manual landing and I was on a hillside.  I tried RTL & it drifted a bit then seemed to freak, so I put it in loiter to just land it.  Nope again.  I'll test it tomorrow, I think it's fine though. 

    • Everything on the Iris works fine (a little twitchy in loiter? Even after a compass cal).  The flight plan went well and it landed at the last waypoint just fine.  

      The gimbal is toast.  I read the other thread where they offered 15% off of the next gimbal.  The wires were severed and it's not doing anything.  For what I'm filming, I just need the camera to point down.  Here's my solution.  I'll figure out something to keep it on & at least I now have a lens & abuse cover so I'll still have a working camera.  I'd upgrade drones, but I'm afraid that these glitches will be the same on a more expensive drone.

      I've spent every weekend fixing this damn thing.  See if it will do a few more job sites for me?  Unfortunately, every time I fix it and it goes really well, there's some glitch on the actual jobs regardless. 


  • Hold down the reset button on the back of the controller. It usually helps when wifi disrupts my binding with my iris. Hope it helps
  • I submitted a request to 3DR after going through their troubleshooting prompts. We'll see what happens?  It lost all contact midair.  It didn't fly away, it just crashed and I had no controls w/ the remote.  Something really isn't working, it won't even bind.  

This reply was deleted.