Bad Compass Health

I'm having a problem with a Pixhawk that came with a 3DR DIY 4X kit. APM Planner is reporting "Bad Compass Health". The compass is an external uBlox GPS combo that came with the kit.

I've tried several solutions that include,

-running APM Planner with the quad outdoors with a clear view of the sky,

-repositioning the GPS/compass antenna further away from the frame
-swapping the 3DR provided GPS/compass combo with a Ublox M8N that I had laying around,
-installing ArduPlane on the Quadcopter, then reinstalling ArduCopter-quad, and
-inserting a new sdcard.

None of these have provided resolution.

I have two other quads with Pixhawks, (one is a genuine 3DR, the other is a BangGood knockoff) and I had not encountered this error with either. Here is a picture from MissionPlanner of the compass settings. Any suggestions as to what might be the issue here? Thanks in advance...3691332525?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Okay- just tried that w/no luck. My other quadcopter does have #2 checked. I just plugged it in to MP and compass is working fine (I'm in a building).

    The only difference that I can see in the two configs is that in the working quad, "Onboard Mag Calibration" on the compass tab has a blank dropdown box, whereas on the quad with the compass problems this box is active and shows "Default" selected. I have tried the other sensitivity settings with no success.

    Martin Lachance said:

    I'd start by un-checking compass #2 and compass #3 then repeat calibration.

  • I'd start by un-checking compass #2 and compass #3 then repeat calibration.

  • Developer
    I would suggest raising this issue on or the Ardupilot facebook group...

    There are no Devs here anymore...
This reply was deleted.