Throttle setting for the Pixhawk

I'm not sure why, but I do not have full throttle when connected to my Pixhawk. The reason I say this is that when I am at half throttle all motors spinning (Y6, newest version firmware loaded), but when I place the flight mode switch to RTL my motors more than double the RPM.  I am running 4S 11AH Lipo and my motors are 400 KV. My radio is Futaba T14SG with Futaba R7008SB receiver connected via S-buss to the pixhawk. I have gone through the Parm's with a fine tooth comb. Cannot find anything out of the norm. This only happens when I switch from Stabilize to RTL. When I switch back from RTL to Stabilize my throttle drops back to where it was before making the  flight mode switch. But I cannot get the motors to run as fast as they did whilst in RTL mode. In fact from half throttle on to full throttle there is nothing but my stick movement on the TX, no increase in RPM. I'm not running props on this thing until I find out what the problem might be. Fear of this Y6 climbing to 10 kilometers or more just frightens me..As of today I have not flown this Y6. Has anyone experienced this problem and if so what did you do to correct?  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Seems to be a slightly overpowered machine ... Klaus idea of wrong throttle_mid is reasonable for me to. If not, test Alt_hold and Loiter before using RTL

  • Did you run the ESC calibration routine after doing your radio calibration?

    • Hi Joel;  Yep done that several hundred times.. I even did each ESC one at a time. No difference, Then did all in one and no difference, to check myself I have watched this in theRadio Calibration Window to see if maybe my mixing was kicking in.. but no it did not.. I redid everything  and did it by the manual for the Pixhawk and checked off each task just to make sure I was getting the results that the manual said.  I uploaded my log to Richard but will have to wait for 15 minutes for the post. Maybe Richard can make heads out of this.. Again it functions properly in Stabilize mode except the throttle is only half throttle but when I place it into RTL mode the motors spin up like crazy. Still stumped in Tulsa.

    • Hi Jim,

      look here, and check your setting

      and here:

      flying Greetings from Germany

  • Is there any chance when you switch to stab the TX is outputting less on ch3 than when in RTL because of a mix in the TX from another set up or something? Dual rates issue accidentally on ch 3?? Wow... it's  stumper!!!   

  • Do you have any throttle curves set on the radio? 

    Also setting throttle hover position is important as it seems to be used in a few calculations. 

  • Did you try a radio calibration again? Does ch 3 look normal aka is it moving the full amount you would expect on the screen? This would eliminate an s-bus issue I would think. 

    • Hi Richard; Try this file it goes from Stabilize to RTL and back again...

      2015-03-30 20-51-10.log

    • I think we need a more experienced log reader here than me. But your baro altitude looks very odd at least to me anyway. I'm not sure if really high vibrations would cause this or what. Your IMU x,y, and Z seem really high but again I'm not an expert. If you have the exact same problem going into alt hold then I think the answer might be with high vibrations not RTL. But that still doesn't explain not getting full throttle in stab mode. Hopefully a dev like say hmmm Randy or Rob or Marco might help out??!! 

    • Hi Richard; I have not flown this platform. I have designed it to be a heavy lifter Canon 40D. But after adjusting THR_MID I wa able to gain the same amount of throttle that I achieved in RTL. Now all I need is to tweak it a little. I need to hover and then down load my log to see where I need to tweak.  Thank you for your time and kind suggestions. It did lead me to finding the correct solution.... Will up load pictures after first flight...jim

This reply was deleted.