Problems, Hints, experience, comments on the new PIXHAWK3689246135?profile=original

1150 Members
Join Us!

You need to be a member of diydrones to add comments!

Join diydrones

Comments are closed.

Comments

  • Hi Tim,

    Thanks for reply.

    I try to do this that you told me, but i only listen long tune of pixhawk and that's all. Here you have video:

    https://youtu.be/HmZwVNINQOo

    In video you can see that i don't switch safety correctly in second time to plug bettery, and after that i did it again correctly and i have the same result (any sound from esc and motors).

    Maybe can be a problem of ppm encoder? i can can check if the ppm encoder works well or the exit of ppm connection (that goes to pixhawk) works well?

    thanks for help again.

  • garvarma,

    The first time you plug the battery in with full throttle engaged, try not using the safety switch. Just plug in the battery, wait for the tunes to clear, and un-plug battery. When you plug the battery back in the second time, wait for a beep then lower the throttle, you should get a confirmation set of tones from your ESC's. I hope this helps you. 

  • Hi,

    I'm mounting my first quadcopter with this hardware:

    - Pixhawk clone

    - 4 sunnysky 980KV

    - Emax 4 in 1 ESC

    - Turnigy 9x version 2 with receiver

    - ppm encoder sum

    When i plug each wire of ESC to ch 3 in the receiver and throttle to max in turnigy 9x, each motor spin on. I configured turnigy  i can move by all flight modes in mission planner (by switch F. mode and GEAR), so i think that turnigy now is correct configured.

    The problem is, when I enter to calibration mode of ESC by: throttle to max, switch on turnigy and plug battery, arm pixhawk with switch button ---> main led of pixhawk flash in RGB colour, then i unplug battery. After few seconds, plug again battery, main led of pixhawk flash in RGB and i listen a long tone, arm pixhawk quick by switch button and switch throttle to min. After few seconds with throttle to min i don't listen any "beep" from ESC and when i switch throttle to max, motors don't spin on.

    Do you know if i have something bad (connection or something) or i must do something else? Please can someone help me?

    I have this video where you can see all: https://youtu.be/9FwnLkH_mkQ

    thanks to everyone

  • Setting up AUX ports on Pixhawk

    I'm using a T8FG Radio and a R6208SB Receiver  and I want to setup AUX ports to operate Retractable Landing Gear, Gimble Pitch, and Lights on a Hexicopter , after setup up in T8FG I will send signal through S-Bus RC-IN to Pixhawk.

    What i need to know , using Mission Planner howto setup on the Six AUX ports.

    I'm aware of the ports are recognised  as;

    1  50

    2  51

    3  52

    4  53

    5  54

    6  55

    I'm using a Receiver Switch to control the light

    The Retractable Gear and Gimble Pitch have their own servo connections

  • I've just completed 6 flights on my QAV540G with pixhawk and everything is running well in stabilised, alt hold and loiter modes. I've downloaded the logs to see if the auto analysis will pick up any issues, but everything is looking fine except the PM FAIL.  All the logs say the same thing, 31 to 33 slow loop lines found. Max 11.5% line 828.

    Can someone please tell me what this means and do I need to be concerned about it. The logging parameter was Default + IMU but I have reset it to just Default thinking that maybe it was using to much resources but I can't see any difference. What should the logging parameter be set at ? I'm really desperate to get an opinion on this as I want to go to the next step and do an Autonomous flight so I can eventually set up for mapping.

    Any and all comments would be much appreciated.

  • Does everyone religiously conduct gps calibrations when starting a new flying session out in the field?
  • Anyone seen or know anything of the Pixhawk 2?

  • It's been awhile so I am not sure how I finally got a similar issue resolved, but I believe I finally got everything working after I had my esc programmed correctly...
  • Tim, you should really consider updating the stock SimonK firmware on the Spiders to the latest one, once done all your sync issue will go away. Also while upgrading SK it is easy to set the min and max throttle settings in the GUI, as simple as typing the numbers and pressing "flash" when done you won't even need to calibrate them, as they all will have the same settings.  The numbers to put in the min and max fields you can get from the MP radio calibration screen, throttle channel. The most recent Spiders have simonk bootloader on them so they support turnigy/afro ESC linker sticks, if you have older hardware, the best way is to use this + this to flash simonk+bootoader, afterwards you will be able to use a turnigy/afro stick to upgrade/change settings/motor direction through the servo lead w/o taking ESCs off the copter or even flash blheli firmware on them. (I use 40A spiders on almost all copters I build and with 22/24 pole motors ESCs blheli runs them cooler with 8hz PWM).  Another great ESC is hobbywing xRotor 40A. Stock f/w is OK, but when flashed with blheli those ESC really perform great. 

  • Thank you Artem and Harry for your input, it's greatly appreciated.

    When I calibrate the ESC's, using the all at once method, they seem to behave fine while in this calibration mode. While still in calibration mode there have been times where one the the ESC's exhibited sync issues and occasionally put out a slight grinding noise.

    If I were to purchase 3DR 20A ESC's, would all of my calibration and ESC's issues definitely go away? I'm beginning to think that this might be the road I need to take. I just hate having to spend $160 if it's not necessary.

This reply was deleted.

Making a phototransistor cable for Canon S110

I want to make a phototransistor cable for my S110 to attach infront of its red eye LED light and connecting it to pixhawk in order to imporve the geotagging process. But I am fairly new with electronic, wiring and soldering stuff.Thus I need help and guidance on how to properly make one. I want to know is this the right connection for me to make the cable.Any help is really appreciated. Thank you.

Read more…
0 Replies

Hexa with Hobbywing X8 motors

Hii am building a hexacopter with1.) hobbywing x8 motors2.) flight controller pixhawk PX53.) battery 12s 22Ah4.) wheel base of around 1800mm5.) estimated weight around 17kg without payloadi am looking if anyone has already tuned this type so i can get a head start. looking forwardthank youMike

Read more…
0 Replies

TAKEOFF WITHOUT USING GPS

Hi,Im working on a autonomous drones and im using JETSON NANO and flight controller PIXHAWK .Im able to control my drone by giving rc commands on the MAVLINK terminal itself by connecting it with PIXHAWK but now i want a python code from which i can do some operations like:takeoff,left ,right,forward,backward…and i am not using GPS…Can anyone please help me…

Read more…
0 Replies

Flashing in Pixhawk

Hi everyone,Recently I've got my first pixhawk CUAV v5+. I'm amazed to see one thing that through one USB port only we can flash code and read the logging data. To understand how is it working I started looking schematic but didn't understand anything. Can someone please tell how is that working?

Read more…
0 Replies