Lost video feed after 1.0.5 update

Flew yesterday with the 1.0.5 update. All's well (haven't seen the GPS problems so far, even pre-update), but I lost the video feed from my GoPro (Hero 4 Silver). Black screen only in the Android app.

Anyone had the same problem? Found a fix?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Nothing changed in Sololink 1.0.5 that would affect the video feed. There was an iOS app update that improved the vast majority of video feed crashes, so making sure you are on the latest iOS app is definitely a good start. (The Android app was always fine) 

    The first thing I check when I see no video is the HDMI connection. It can be very tricky and can seem fully plugged in even when it isn't. Often I'll try to remove the GoPro from The Frame to get a better perspective to see if the HDMI plug is in properly.

    Also, the GoPro video format needs to be NTSC. It will not work in PAL. An update to support PAL is coming very soon.

    Sometimes the video feed can just crash. Rebooting the solo, controller, GoPro, and quitting the app can sometimes fix it. The order in which you turn them on should not matter.

    It can also be a good idea to inspect for damage on the male connector on the cable and the female connector on the GoPro.

    Sometimes the GoPro can be somehow broken. If possible, it is helpful to isolate the issue to the GoPro or the Solo by trying other cameras (gopros or anything with micro-hdmi-out) into the Solo or trying to connect your GoPro directly to another monitor or TV with a micro-hdmi to full-hdmi cable. 

    Good luck!

    • Sounds like a pain...why is it doing that?

  • Live view worked a few times after the update for me although it has been intermittent out of the box and often have to restart everything  to get live view to start working again. (GoPro 4blk and 3h+).  Then 2 days ago I landed solo from a short flight with live view working, stopped the recording started a new recording(not sure if live view was working at this time) went to initiate the motors and recived a caliberation error which happens about 1 out of 4 attempts to start the motors after a gps lock. restarted solo and live view hasn't worked since. I took her up one more time using line of sight to make sure solo was still functioning. but that is it. couldn't perform any of the missions I  had planned that day with the family with out live view... been grounded since after going through all the trouble shooting steps several times and just now tried a few things I saw listed in this thread....still black screen.  even reset gopro's and they test fine outputting over hdmi to my monitors. 

  • Eric:

    I lost video in 'startup' about a week ago. Rechecked all hookups, Solo Link re-connected, restarted, rebooted, etc. and tried everything. Called Solo Tech Support and a nice fellow led me through all the above again. We found nothing and he finally declared Solo was probably OK and I should check with the GoPro people. Before I called them, I opened the GoPro APP on my Galaxy S-4 phone and connected to the GoPro camera on the direct GoPro Wi-Fy. I brought up 'settings' and went down the entire list of settings for my HERO4 Black. I found that the 'Video Format' setting had somehow been changed to 'PAL' from 'NTSC' (Standard for US). I changed the setting back to 'NTSC',  set it all up for flight again and had good video after startup. No problem since on several following flights.

    • Finally got mine working. Tried various GoPro settings and 720/30fps was the trick. Also noticed that successful video feed may be dependent on the mobile device. 720/30fps worked on Nexus 7 (2013) but not on my Moto G (2nd gen).

      Thanks to all for your suggestions. Sounds like there are a variety of problems and solutions regarding video feeds.

      I also received feedback from 3DR tech support. Didn't try since the above was successful.

      If you are getting no video feed from your GoPro please check the following:

      Make sure the Camara has a full charge.
      Check on your Camara to make sure if you are in the USA have NTSC and if you are located outside the United States please select PAL.
      Change resolution on the GoPro to 1080/60 medium.
      Make sure that the camera is properly connected to the HDMI cable.
      If that does not work please do a power cycle following steps:

      Turn off SOLO.
      Disconnected GoPro from SOLO.
      Turn off GoPro.
      Close APP.
      Connect GoPro to SOLO. -Turn on: SOLO > GoPro > Controller > and App. -Make sure the WiFi is off ( on camera)
      At the moment there is a known issue if you are using an iPhone 6 with the IOS 9.0 beta it will make the app crash, you will need to go to the previous version of IOS.

      Best Regards,

      Tech support
      Mon-Sat 8am-5pm PST
      (858) 225-1414


  • Developer

    My video worked for one flight after the update but then stopped and I can't get it working again.  It seemed to stop after I changed batteries on the Solo (obviously not related except that the vehicle was powered down and back up again).  I also modified the FPS to 60 to reduce the jello effect.. Not sure what exactly caused it to stop working but plugging/unplugging, restarting solo/controller/app - nothing seems to help.

    I'm using a GoPro 3 silver.

    • I have mine set at 720 / 60 FPS, medium. The only time I lost video is when the GoPro battery died. I have read elsewhere that if the battery is substantially low you may not get video. Also, might try uninstalling and reinstalling the app. If you have a cable see if you can get video to a tv or monitor from the GoPro.
    • Hey Randy,

      I have seen others with the same problem that had to set their GoPro to 1080/30 M and they would get a picture. After that they could change it back to 60. It doesn't make sense but has worked for others.

    • Developer


      Ok, thanks.  I don't seem to be able to switch it to 1080/30 "M".  My GoPro 3's display says 1080 - 30 and it has a little "W" up by the video camera icon.  I can't seem to put it into "M" (which I guess means a reduced field of view) perhaps because it's a GoPro3 silver (not a GoPro4 or even a GoPro3+).  Ah well.

  • Yes!I can se the app, sorry,misunderstood.
This reply was deleted.