No WiFi from Solo

Just got my Solo today, woo hoo!  That's where the good news stops, ha ha.

I start to go through the process of updating and the Solo boots up and gives me the correct color lights.  The remote says preflight update required and is on.  But no WiFi is being transmitted.  I can't see WiFi on my iOS, OSX, or Android devices.  So I'm stuck.

Also, not sure if this is related.  I can't turn off the remote once it's on and stuck on the preflight update screen.  I can hold the power button until the controller shakes a little but it doesn't power down.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello Rich, did you try resetting the controller? May have to remove the battery and start over. Good luck.
    • I did find the factory reset procedure and tried it.  Nothing happened, it just booted to the waiting for update screen.  Never reset and never started to broadcast Sololink.

      Luckily another Best Buy had one in stock and I was able to exchange it.  Second one worked beautifully!

    • Great. Can't wait for mine to come in. Happy flying.
This reply was deleted.