We operate a DJI S900 with A2 controller, Z15-N gimbal and 2.4 GHz Data Link dedicated to photogrammetric surveys. Our experience, having tried a number of alternate configurations, is that UgCS will not trigger the camera. The Gimbal Control Unit 'Shutter' and 'Mode' ports are connected to the A2 General Purpose Servo ports 'F2' and 'F3'.

Are there any A2/Z15 operators who are using UgCS for photogrammetry who could offer suggestions? Is photogrammetry possible with this hardware using UgCS?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have tried the same method, and when I click trigger in the GS software when I set the GP Servo action, my camera takes more than 1 picture. I am not using a zenmuse gimbal by the way.

  • Yes Douglas, it works like charm. Our equipment: DJI S900, A2 controller, Zenmuse GH4, 2.4 GHz datalink, and (of course) UgCS.

    Our microsite (sorry, only Spanish by now): http://modelos.aerosar.es

  • Thanks for the replies. We're using UgCS v. 2.11 running on Windows 7.

    The aircraft will execute a flight plan under UgCS control, but the camera will not trigger. The GCU 'SHUT' port is connected to the controller 'F2' port and "vehicle.dji.trigger_action = -1000, 1000, 1 ".

    The shutter operates normally under RC control, as do other gimbal functions. There is an undated manual that specifies disconnecting the GCU/CAN-bus and unmmapping the gimbal and D1-D4 channels. We tried that, and it disabled RC control, but did not establish UgCS control.

    I'm glad to hear you're having success with similar equipment. we're looking forward to putting our bird to work.


  • We have found that Z15 gimbal is not the most user friendly product, unfortunately because DJI have not built it in order to control Pitch/Yaw using Flight controller (A2 for example) and RC control of pitch is also a bit confusing.

    Please see this guide, I hope it will help you: https://www.ugcs.com/files/PDFs/Manuals/v2.10/Connecting_DJI_A2_WKM...



    UgCS Team

  • I'm using  the same confiiguration (except the Z15-GH4). Find the "shut" cable in the gimbal contoller, it should go to he RC receiver (Futaba in my case). Unplug it from the receiver and plug at F2 port on the A2. This way UgCS can control the shutter.

    Also make sure you have correct values for the "vehicle.dji.trigger_action" parameter in vsm-dji.conf file.

    It is all explained here:  https://www.ugcs.com/files/2016-04/1460983056_manual-dji.pdf

This reply was deleted.